MATLAB Answers

Soeren
0

Problem during installation of support for TI C2000

Asked by Soeren
on 17 Jan 2017
Latest activity Commented on by Soeren
on 26 Jan 2017
Hello,
I've tried to install the Support for TI C2000 processors. I'm using Matlab R2016a, CCS6.1.3 and ControlSuite v3.4.4. For the installation I used the following support link: https://de.mathworks.com/help/supportpkg/texasinstrumentsc2000/ug/install-support-for-c2000-processors.html?requestedDomain=www.mathworks.com
So first I installed the Embedded Coder Support Package for Texas Instruments C2000 Processors. Then I tried to do the additional Setup Tasks. As toolchain I selected "Texas Instruments Code Composer Studio v6 (C2000)". The following validation of the Code Composer Studio installation worked without any problems, but when I tried to validate the ControlSuite Installation, a error message was displayed which says "Incompatible Texas Instruments Code Composer Studio v6 (C2000) Installation. Expected Version 3.3.9 but found Version 1.2." So I tried to download Version 3.3.9 of the ControlSuite but unfortunately older versions of the ControlSuite are not available from TI. Then I installed the Code Generation Tools 6.4.6 (Before I used Code Generation Tools v15.12.1.LTS) which are proposed in the "Install third-party Software"-window but it didn't help: The Validation of the Code Composer Studio was again successful but not the validation of the ControlSuite Installation.
Does anyone know how to solve this Problem? Thanks in advance for your help!
Soeren

  2 Comments

Hi, Same problem, but i sloved it. Check first line of "<install Dir>\ti\controlSUITE\Release Notes.txt", edit and replace "v 3.4.4 - December 09, 2016" with "v3.4.4 - December 09, 2016"
Hi Milen,
thanks for your help! Unfortunately I didn't receive an Email that you commented on my question. So I directly tried the solution proposed by Sumith which also worked :)
Soeren

Sign in to comment.

1 Answer

Answer by Sumith Sekharan on 25 Jan 2017
 Accepted Answer

Hi,
This was a compatibility issue with latest version of controlSUITE. This is fixed in the latest version (16.1.3) of TI C2000 support package. Hope this helps.
Thanks, Sumith

  1 Comment

Hi Sumith,
thanks for your help! Now it works :)
Soeren

Sign in to comment.