Getting 'empty' Compiled Port Data Types

16 views (last 30 days)
Siddhesh Wani
Siddhesh Wani on 3 Jul 2023
Commented: Paul on 8 Jul 2023
I'm trying to write a script to get datatypes of an inport and a outport of a subsytem/block. When I run following command:
an empty array/structure is returned. Model is compiled before running this command. 'CompiledPortDataDimensions' also returns an empty results.
  1 Comment
Paul on 4 Jul 2023
I had similar issues in this Question. Never got it sorted out and never contacted Tech Support.
If you do get this sorted out, please post the solution either here and/or in the linked question.

Sign in to comment.

Answers (2)

VBBV on 3 Jul 2023
Edited: VBBV on 3 Jul 2023
Run the model once (insted of just compiling) and check if model generates any data from ports and call or run the command
Possibly no data might have been generated by model
VBBV on 4 Jul 2023
Edited: VBBV on 4 Jul 2023

Ok. Test your model with valid inputs or input range. Before running your model, check simulation settings also e.g. time scale for simulation etc. A reasonable time duration. If the same problem exists then verify for any model inconsistencies.

BTW , how is the data being read from I/O ports ? Do you use read or some other functions to read data from ports ?

Siddhesh Wani
Siddhesh Wani on 4 Jul 2023
This model is interfaced with other model for reading data. Even if I connect a constant block to inport of model or any subsystem inside model, I dont get the compiled data types. I receive following output after running command:
ans =
3×1 cell array
{0×0 char}
{0×0 char}
{0×0 char}
I even tried creating a simple test model (few inports, outports and a subsystem) and check for this command. It is not working in new model also. I'm not sure if I'm getting a correct port handle. I'm running following commands in order:
sys = get_param('test1','Handle');
list_of_subsystems = find_system(sys,'BlockType','SubSystem');
ports = get_param(list_of_subsystems(1), 'PortHandles');
inports = ports.Inport;
Is there any other way to get port handles and read datatype? I would like a way to specify the model name (not the way using 'gcbh').

Sign in to comment.

Andy Bartlett
Andy Bartlett on 7 Jul 2023
Edited: Andy Bartlett on 7 Jul 2023
Set model in compile mode to access data types
This may be changing, but historically at least, compiled port data types are available only when the model is actively in compiled mode.
mdl = 'fxpdemo_feedback';
% "Lock" model in compiled mode
% NOTE: you will not be able to edit or even close model
% until compiled mode is terminated !!!
% TIP: Use try catch to avoid being unwittingly stuck in compile mode
blk1 = 'fxpdemo_feedback/A2D';
pdt1 = get_param(blk1,'CompiledPortDataTypes');
blk2 = 'fxpdemo_feedback/Controller/Combine Terms';
pdt2 = get_param(blk2,'CompiledPortDataTypes');
pdt1, pdt2
pdt1 = struct with fields:
Inport: {'double'} Outport: {'sfix8_En4'} Enable: [] Trigger: [] State: [] LConn: [] RConn: [] Ifaction: [] Reset: [] Event: []
pdt2 = struct with fields:
Inport: {'sfix32_En12' 'sfix32_En12'} Outport: {'sfix32_En12'} Enable: [] Trigger: [] State: [] LConn: [] RConn: [] Ifaction: [] Reset: [] Event: []
Andy Bartlett
Andy Bartlett on 7 Jul 2023
1) Yes, there is definitely a more modern syntax to get into compiled mode that what I should. The command you gave looks correct (but I didn't test it).
2) Yes, "must be in compiled mode" is more correct / clearer IMHO.
3) Yes, when stopped in the Simulink debugger, the model should still be "in compiled mode."
Paul on 8 Jul 2023
Hi Andy,
Thanks for the response. It turns out that this command
results in an error.
Do you know if there is a doc page that discusses all of the valid setting for SimulationCommand? I can only find example uses, but not a complete list.

Sign in to comment.


Find more on Programmatic Model Editing in Help Center and File Exchange





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!