Clear Filters
Clear Filters

Installation path is not accessible

7 views (last 30 days)
Mathias Mettauer
Mathias Mettauer on 3 Mar 2021
Answered: Rashed Mohammed on 10 Mar 2021
Running a Kubuntu 20.04,
sudo chown -R $USER /usr/local/MATLAB/R2020b
does not solve the problem. Any ideas?
Mathias Mettauer
Mathias Mettauer on 8 Mar 2021
Edited: Mathias Mettauer on 8 Mar 2021
This is strange.. Because it's acutally not the first time this happend to me. Two Years ago, I had the same problem with MATLAB and Ubuntu18.04. I solved it, with extracting all Package-files manually and added to the path. I could do it again like this, but I thought I am not the only one with this problem.
I installed like you proposed, only the unzip-flags I'm not sure -> I will test it now. After Installing, "/usr/local/MATLAB/R2020b" was root-owned, and I was not even able to change the path. With sudo ./matlab there are licencing-errors.
sudo chown -R $USER /usr/local/MATLAB/R2020b
I was now able to change the path, but confusing why I cannot install the mltbx-Package. You can install the Package without the "chown"-command?
Mathias Mettauer
Mathias Mettauer on 8 Mar 2021
Just reinstalled with "unzip -X -K"
No improvement so far: Still the same error

Sign in to comment.

Answers (1)

Rashed Mohammed
Rashed Mohammed on 10 Mar 2021
Hi Mathias
As I was not able to reproduce the issue successfully, I suggest you to contact the author of the toolbox directly. If you feel this is an issue with your MATLAB installation, please reach out to MathWorks support team to help you resolve the issue


Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!