Clear Filters
Clear Filters

Simulink Real-time target PC ‘black screen’ problem

2 views (last 30 days)
I'm struggling with Simulink Real-time not working on target PCs (ADL120s). I have confirmed that Simulink Real-time works successfully on other common desktop PCs.
A black screen appears during network booting and USB booting, and nothing happens.
We want to mount the Simulink Real-Time system in a small robot. Unfortunately, SpeedGoat's hardware is so heavy that it's impossible to mount it on a robot. Therefore, I decided to use embedded PC ADL120s. The ADL120s are lightweight industrial embedded PCs capable of EtherCAT communication with an Intel i210 controller (with i219-LM). Detailed specification of PC is as follows.
Specification of ADL120s 2018.pdf
The methods I have tried
1.I've enabled the PXE and the UEFI network stack option on the BIOS of the target pc (ADL120s)
2. I tried USB boot, Ethernet boot, and various options that can be set (USB support, Multicore, etc…).
3. Try with various versions of Matlab (Matlab R2014b ~ R2019b)
4. I did all of the above with two or more development PCs.
5. Verify that it works successfully when you apply the above method to a general desktop PC.
I want to solve this problem quickly.
If there is a problem with the hardware configuration of the target PC, can you give a guide to the selection of the target PC running Simulink Real-time?
(As mentioned above, the SpeedGoat hardware is heavy and impossible to use.)
Can anyone recommend an embedded PC or Mini-itx motherboard with more than I7 6th generation computing power?

Answers (1)

Diego Kuratli
Diego Kuratli on 3 Jan 2020
Speedgoat is introducing a new small form factor and light-weight target machine, please reach out to the Speedgoat sales team for further information.




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!