Data Augmentation not working

14 views (last 30 days)
Hridayi
Hridayi on 14 Nov 2019
Answered: Mahmoud Afifi on 2 Apr 2020
Hi,
I'm trying to do data augmentation using 'ImageDataAugmenter' on a PixelLabelImageDatastore but the rate of my training is not decreasing (as it should if more images are added).
I'm not getting any error but the my training progress shows the same number of iterations and epochs as my non-augmented dataset.
This is my code:
imageAugmenter = imageDataAugmenter( ...
'RandRotation',[-10,10], ...
'RandXTranslation',[-10 10], ...
'RandYTranslation',[-10 10])
augimds = pixelLabelImageDatastore(imds,pxds,'DataAugmentation',imageAugmenter,'OutputSize',imageSize)
trainedNet_aug = trainNetwork(augimds,lgraph,options)
Does Data augmentation add new images to the datastore? Because it still shows my original 300 images in the augimds variable.

Accepted Answer

Jyothis Gireesh
Jyothis Gireesh on 18 Nov 2019
As per the MATLAB documentation for imageDataAugmenter, the augmented images are not saved to memory. So, the size of augimds would effectively remain the same in MATLAB workspace. But these images are used while training.
You may refer to the following link on imageDataAugmenter for any clarifications.
  2 Comments

Sign in to comment.

More Answers (1)

Mahmoud Afifi
Mahmoud Afifi on 2 Apr 2020
Check this augmenter.
It applies color augmentation and is shown to improve the accuracy for image classification and semantic segmentation. Check the paper for more details.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!