MATLAB Answers


Not able to connect zynq7010 to MATLAB

Asked by TARIQ ABDUL RAHMAN on 19 Mar 2019
Latest activity Answered by Stefanie Schwarz on 17 Jul 2019
Hello, I'm using zybo z710 series zynq hardware for my project, and I'm trying to connect MATLAB 2018b to my zynq harware. My operating system is Windows 10.
I followed the first 10 steps exactly as given in the workflow below,
When I tried running it, I'm getting the following error,
"Error using codertarget.zynq.internal.LinuxShell/setupZynqHardwarecodertarget.zynq.internal.LinuxShell/setupZynqHardware (line 543)
Cannot connect to "Zynq hardware". Details: Could not connect to the hardware over Serial Port.
Check that USB cable is plugged into 'USB-to-UART' port of the hardware and the power switch is turned on.
If this error persists, switch off the hardware, wait for 10 seconds, switch on the hardware and then repeat this step.
Error in codertarget.zynq.internal.LinuxShell (line 207)
Error in zynq (line 113)
h = codertarget.zynq.internal.LinuxShell('ZC702', varargin{:});"
Is there anyway to debug this?

  1 Comment

I'm also receiving the same error with the same setup (Zybo-z7-10, MATLAB 2018b, Win10).
Help would be much appreciated.

Sign in to comment.




3 Answers

Answer by Stefanie Schwarz on 17 Jul 2019

Hi Tariq,
there could be many reasons why you are getting this error message. It could be a basic connection issue, or the board did not properly boot our Linux image from SD card, etc.
Please follow below troubleshooting guide:


Sign in to comment.

Answer by Akshay Khadse on 28 Mar 2019

Please try to reset everything before connecting:
  • Delete everything on the SD card
  • Get the correct IP address of the hardware board
  • Ensure that only the support pacakge for the hardware being used is installed


Hi, I'm having the same issue and I don't know how to find the IP adress of the hardware, I tried using putty to find the ip adress but it seems like it doesn't work once I set all the configurations as mentioned in the example below,
however the linux image i copied into sd card seems to work fine, it is booting and 'P-DONE' Led blinks, but still i get the same error, is there anyway to resolve this?
Tools such as nmap can make it easier to explore what is on your network.

Sign in to comment.

Answer by Efkan Yilmaz on 3 Jul 2019

I have same error. I guess matlab hdl coder and verifier dont support zybo z7. Dou you have any method to solve this problem?


Sign in to comment.