Clear Filters
Clear Filters

getting error: Can't reload '/usr/loca​l/MATLAB/R​2018a/bin/​glnxa64/li​bmwsl_grap​hical_clas​' when trying to use tabularTextDatastore

19 views (last 30 days)
I'm using Matlab R2018a on a ubuntu 18.04 server and when trying to use tabularTextDatastore i got the next error:
identifier: 'MATLAB:err_while_looking_up_function'
message: 'An error occurred while trying to determine whether "readData" is a function name.'
name: 'tabularTextDatastore'
line: 120
identifier: 'MATLAB:dispatcher:loadLibrary'
message: 'Can't reload '/usr/local/MATLAB/R2018a/bin/glnxa64/''
I checked /usr/local/MATLAB/R2018a/bin/glnxa64/ and the file is there....
  1 Comment
Niklas on 22 Feb 2019
We see this error as well. We already tried to reinstall Matlab and Ubuntu several times. We found that the issue does not occure when we only install Matlab and Matlab Coder without any Toolboxes. If Toolboxes, like Machine Learning Toolbox, are additionally installed the error is back.

Sign in to comment.

Answers (2)

Niklas on 22 Feb 2019
We talked to the Tech support on this. They suggested to install openjdk-8-jre as it depends on the same packages.
sudo apt-get install openjdk-8-jre

kira on 22 Feb 2019
I solved it by creating a directory named "exclude" within "/usr/local/MATLAB/R2018a/bin/glnxa64/" and puting "" in it
Gowtham Dubakula
Gowtham Dubakula on 26 Mar 2021
i faced this error while opening simulink . I did this method again this error coming , what i have to do now?

Sign in to comment.


Find more on Introduction to Installation and Licensing in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!