MATLAB Answers

Different time response of same trasfer function in matlab and simulink

10 views (last 30 days)
Mehran
Mehran on 9 Aug 2018
Edited: Ameer Hamza on 10 Aug 2018
I am modeling the mechanical component of an accelerometer and tf is MechCmp =
4.313e-09
---------------------------------
4.313e-09 s^2 + 0.05545 s + 149.9
when i use step(MechCmp) i get this response
but when i give step ip to its Simulink tf block of the exact same values it takes much time and gives a straight line as o/p. I also tried LTI block and state space model of the same tf but problem is same.i found answers saying that simulink uses ode solvers instead of fixed sample time, can anyone explain to me how to do disable ode solvers or use fixed sample time in simulink. or anyother suggestion

  0 Comments

Sign in to comment.

Accepted Answer

Dimitris Kalogiros
Dimitris Kalogiros on 9 Aug 2018
At simulink, you have to go to Model Configuration Parameters
Then you can change your solver:
I suggest " variable-step discrete " solver

  1 Comment

Mehran
Mehran on 10 Aug 2018
thank you for your response, i did this but i got this error "The "VariableStepDiscrete" solver cannot be used to simulate block diagram 'step' because it contains continuous states", I have tried different sample times for step ip but same error

Sign in to comment.

More Answers (1)

Ameer Hamza
Ameer Hamza on 9 Aug 2018
The Simulink is giving the same plot as MATLAB, the problem in the display is happening because The system step response has a very small magnitude (approx 2.9e-11) and the settling time is also very small (approx 2e-3 seconds). You need to scale the scope axis properly, to see the same graph. Change the Simulation Stop time to 0.01 seconds and scale the axis using the button shown in the red box

  2 Comments

Mehran
Mehran on 10 Aug 2018
thank you for your response which version of matlab you are using i have 2015 and i have this kind of interface
</matlabcentral/answers/uploaded_files/128444/Untd.png> and when i autoscale it i get the response in attached picture
Ameer Hamza
Ameer Hamza on 10 Aug 2018
I am using R2018a. Please try to run the attached file to see if it work correctly.

Sign in to comment.