Cannot program Arduino Uno Board

128 views (last 30 days)
Liew Yean Choon
Liew Yean Choon on 19 Jun 2018
Commented: Rushabh Kalmate on 6 Dec 2021
Hi, I'm facing problem to connect my Arduino Uno board using MATLAB. I have search around the internet for around 7 hours and still cannot find the solution. I am really in big problem, I need to for my assignment. Can anyone help me please?
>> a = arduino();
Updating server code on board Uno (COM23). Please wait (might take a few minutes).
Cannot program board Uno (COM23). Please make sure the board is supported and the port and board type are
correct. For more information, see Arduino Hardware Troubleshooting.
I have tried changing the name of C:\User\user_name\Documents\Arduino file to other name but when I run the program again a new Arduino file is created in C:\User\user_name\Documents\.
  1 Comment
Liew Yean Choon
Liew Yean Choon on 19 Jun 2018
this is my a = arduino('COM23','Uno','Trace',true)
"C:\Users\ACER\AppData\Local\Temp\ArduinoServer\MW\core\WInterrupts.c.o"
c:\programdata\matlab\supportpackages\r2017b\3p.instrset\arduinoide.instrset\arduino-1.8.1\hardware\tools\avr\bin\../lib/gcc/avr/4.9.2/../../../../avr/bin/ar.exe:
unable to rename 'C:\Users\ACER\AppData\Local\Temp\ArduinoServer\MW\core\core.a'; reason: Permission
denied
Using library MWArduino in folder:
C:\ProgramData\MATLAB\SupportPackages\R2017b\3P.instrset\arduinoide.instrset\arduino-1.8.1\libraries\MWArduino
(legacy)
Using library Wire at version 1.0 in folder:
C:\ProgramData\MATLAB\SupportPackages\R2017b\3P.instrset\arduinoide.instrset\arduino-1.8.1\hardware\arduino\avr\libraries\Wire
Using library Servo at version 1.1.2 in folder:
C:\ProgramData\MATLAB\SupportPackages\R2017b\3P.instrset\arduinoide.instrset\arduino-1.8.1\libraries\Servo
Using library SPI at version 1.0 in folder:
C:\ProgramData\MATLAB\SupportPackages\R2017b\3P.instrset\arduinoide.instrset\arduino-1.8.1\hardware\arduino\avr\libraries\SPI
exit status 1

Sign in to comment.

Answers (7)

Rajat Ligade
Rajat Ligade on 11 Apr 2020
I had Tx and Rx pins connected to something. I removed those pins and reran the code. the error is gone
  1 Comment
Bart Kieviet
Bart Kieviet on 4 Oct 2021
This solved the above problem for me.

Sign in to comment.


zhe cheng
zhe cheng on 18 Apr 2019
change the port
it helps.

Menghan
Menghan on 19 Jun 2018
Can you first confirm that the downloaded Arduino IDE works fine on your computer? To do that, go to the folder which is returned by typing "arduinoio.IDERoot" in MATLAB and then open the IDE manually. Try upload an empty sketch to the same board and see if you get the same error.
If yes, check if you have write permission to this folder C:\Users\ACER\AppData\Local\Temp\
  4 Comments
Rushabh Kalmate
Rushabh Kalmate on 6 Dec 2021
After sucessesfull installation of support package for arduino hardware , i am facing problem for hardware setup . i have choosen usb cable type connection , After selecting correct board "uno" and port "COM7" and clicking on programme it is showing "First input can not be empty. Expected a non-empty character vector or a valid file-id."

Sign in to comment.


Luis Delfin Puron
Luis Delfin Puron on 23 Sep 2018
I was facing the same problem and solved it by setting the variable arduinoio.IDERoot to an address which current user has access to read and write. In my case it was: arduinoio.IDERoot = 'C:\\Program Files (x86)\\Arduino' Hope it helps.
  1 Comment
fatima zohra soussi
fatima zohra soussi on 11 Oct 2020
i dont understand what i should do i have same problem ?

Sign in to comment.


Ogheneovo Idolor
Ogheneovo Idolor on 5 Apr 2019
Try running MATLAB as Admin. Worked for me.

ybshokouhi
ybshokouhi on 30 Jan 2020
I am having the same problem. Any updates on this?
  1 Comment
adrian paeckel
adrian paeckel on 29 Mar 2020
I had the same problem. When trying to program my arduino mega 2560 on MATLAB I would see the Adruino IDE logo for a few moments before the error raised. The problem and solution I found is that I had installed an earlier version of the Arduino IDE on my Mac but the IDE contained in the Support Package on MATLB was an older one. So I replaced the old one, contained in the address which you get typing arduinoio.IDERoot in MATLAB command, for the latest one and it works fine now.

Sign in to comment.


Andrew Loots
Andrew Loots on 22 Jul 2020
I have Aduion Uno and it loads fine if I do not load the Paulstoffregen/One Wire library. As soon as I add the library it throws the' cannot program board " error.
Please help

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!