Clear Filters
Clear Filters

Can't reload '/usr/loca​l/MATLAB/R​2017b/bin/​glnxa64/li​bmwdastudi​o.so'

102 views (last 30 days)
I get this error message when I try to open simulink on Scientific Linux and Fedora.
  2 Comments
Thirunagaru Deekshith
Thirunagaru Deekshith on 18 Jan 2021
Edited: Walter Roberson on 18 Jan 2021
$ cd /usr/local/MATLAB/R2017b # Matlab directory
$ cd bin/glnxa64
$ mkdir exclude
$ mv libfreetype* exclude
$ cd ../../sys/os/glnxa64
$ mkdir exclude
$ mv libstdc++.so.6* exclude
$ cd
These commands worked for me
Alfio Messina
Alfio Messina on 16 Apr 2024
Edited: Alfio Messina on 16 Apr 2024
This solution worked for me. Thank you!!!
I'm on a Ubuntu XFCE virtual machine and MATLAB R2017b.

Sign in to comment.

Answers (4)

Edward Pacman
Edward Pacman on 31 Mar 2018
Same issue, none missing from "ldd". R2018a on Arch Linux. So maybe solved in R2018b?
  5 Comments
Abhinaba Saha
Abhinaba Saha on 8 Apr 2019
Thanx, The solution provided in BBS#202575 solved my problem too....!!
solution link: https://bbs.archlinux.org/viewtopic.php?id=231299

Sign in to comment.


Rajesh Balagam
Rajesh Balagam on 17 Oct 2017
It may be possible that some dependent libraries for 'libmwdastudio.so' are missing in the system. Check if all the dependencies are present for this library by performing the following steps:
1. Using a terminal, navigate to the directory where the library is found:
>> cd /usr/local/MATLAB/R2017b/bin/glnxa64
2. Then run the 'ldd' command as shown:
>> ldd libmwdastudio.so
3. Observe for any missing libraries in the output. For example:
libXt.so.6 => not found
libXext.so.6 => not found
4. Install the missing libraries
  3 Comments
xiaotong Sun
xiaotong Sun on 13 Dec 2017
hi, Rajesh Balagam
I meet this issue,too. I did as your steps but I didn't have any missing libraries. And after that I still have the problem when I invoke Simulink in Matlab2017b. It also showed "Can't load glnxa64/libmwjmi.so": GLNXA64/libQt5WebEngineCore.so.5: undefined symbol: XFreeEventData
Thanks, Xiaotong
Eric Smith
Eric Smith on 18 Jan 2018
I have the same problem on Fedora 27. Running "ldd libmwdastudio.so" shows that all libraries are found, none missing. I am running matlab using the symlink the installer created. I installed matlab in /opt/matlab-r2017b, and the simlink is to /opt/matlab-r2017b/bin/matlab.

Sign in to comment.


foboo
foboo on 29 Nov 2017
In my case this happened because I called
${MATLAB_ROOT}/bin/glnxa64/MATLAB
instead of
${MATLAB_ROOT}/bin/matlab

R Seyon
R Seyon on 27 Jan 2021
I had same problem . I have successfully solved this error by ( Matlab 2018a on linux mint 20.1 ) following below tutorial
Summary of this tutorial
-------------------------------
Can't reload'/xx/xx/xx/libmwdastudio.so
The reason for the problem: Matlab cannot load the font to display $ MATLAB / bin / glnxa64 / libfreetype.so.6;
Solution: Solve by cre

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!