Interfacing GAMS and MATLAB - worked well in MATLAB R 2009b - Showing Errors in MATLAB R 2013a - Reg

9 views (last 30 days)
I interfaced GAMS win32 24.7.4 software with MATLAB using the procedure explained in youtube video. I run the GAMS program from MATLAB R 2009b. successfully. But when i wanted to run the same GAMS file from MATLAB R 2013a , it is giving error message. The error message is shown below.
Input command :- system 'gams trnsport lo=3 gdx=solution'
*** Error: Error writing GAMSNext: Permission denied.
How can I solve this problem.

Accepted Answer

Kallam Haranadha Reddy
Kallam Haranadha Reddy on 26 Nov 2018
I have found the answer for my question on interfacing GAMS with matlab for myself. I have solved the problem of interfacing GAMS with matlab ,

More Answers (1)

Kallam Haranadha Reddy
Kallam Haranadha Reddy on 22 Dec 2018
I did the following to interface 'GAMS win64 24.9' with MATLAB R2015b'.
Add GAMS directory to the matlab path.
change the matlab present working directory to GAMS system directory ( for ex, C:\GAMS\win64\24.9 ) in my system.
Type the following in the matlab command prompt.
>>system 'gams ? lo=3'
Next type the following at the matlab command prompt,
>>system 'gamslib trnsport'
(we want to run transport file from GAMS model library)
Next to execute the transport GAMS file from MATLAB, type the following
>> system 'gams trnsport lo=3 gdx=solution'
To view the results in GDX form, type
gdxWhos('solution')
or
gdxInfo('solution')
  4 Comments
Walter Roberson
Walter Roberson on 15 Apr 2020
messages about module not found tend to indicate that there is a missing dll that is called by the file indicated. Sometimes you can use tools such as Dependency Walker, or Process Monitor to see what is missing. It is probably most common to end up needing to install Visual Studios Runtime
https://www.raymond.cc/blog/check-what-dll-or-ocx-dependency-files-is-needed-for-a-software/

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!