Clear Filters
Clear Filters

why is my PI controller having no output when it has inputs?

4 views (last 30 days)
i have a model in simulink power system of R2013a but when i run the simulation, the PI controller does not give an output. i have checked and its inputs are ok. i have tried different solvers with no change but when i change the time domain of the controller from discrete to continuous time, it gives this error message
"Derivative input 15 of 'wind_and_gen/powergui/EquivalentModel1/State-Space' at time 0.0 is Inf or NaN. Stopping simulation. There may be a singularity in the solution. If not, try reducing the step size (either by reducing the fixed step size or by tightening the error tolerances)"
please can anybody help out with how to check/solve singularity or what to do with the pi controller in discrete time domain to give an output?

Accepted Answer

Muhammed Fasil
Muhammed Fasil on 8 Feb 2016
Click on that error message and at the error point of simulink file use a "UNIT DELAY" block and run simulation again

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!