I get message "ANSYS Program has stopped working" when I try to run Ansys by Matlab!

9 views (last 30 days)
I prepare a matlab code that has to use Ansys somewhere. I tried following lines;
dos('"C:\Program Files\ANSYS Inc\v140\ANSYS\bin\winx64\ansys140.exe" -p ane3fl -dir "C:\..." -b -i "C:\..\input.txt" -o "C:\...\file.out"')
%
!"C:\Program Files\ANSYS Inc\v140\ANSYS\bin\winx64\ansys140.exe" -p ane3fl -dir "C:\..." -b -i "C:\..\input.txt" -o "C:\...\file.out"
This line works properly on command prompt. But in Matlab (R2014b), Ansys stops working immediately.
I even try to write cmd lines as *.bat file and call it to Matlab however it doesn't work.
How can I fix this problem?
Thanks

Accepted Answer

Sarah Palfreyman
Sarah Palfreyman on 10 Jan 2017
See ANSYS for the MATLAB AAS Toolbox interface.

More Answers (3)

Dan Li
Dan Li on 9 Nov 2015
I met the same problem. Have you solved it?
  1 Comment
Enes Tunca
Enes Tunca on 9 Nov 2015
That is still unsolved. I skip to seeking an answer for this situation, I just uninstall the current Matlab and install version R2013a. That solved my problem more quickly.

Sign in to comment.


Walter Roberson
Walter Roberson on 9 Nov 2015
Use Dependency Walker on ANSYS outside of MATLAB to find out which C or C++ libraries it needs. Then when you set up the dos() or system() command inside MATLAB, set up the environment so that the directory is on the search path; more on that in https://msdn.microsoft.com/en-us/library/windows/desktop/ms682586%28v=vs.85%29.aspx and http://stackoverflow.com/questions/694351/setting-library-path-for-win32-console-applications

Akshay Kumar
Akshay Kumar on 13 Jun 2018
Edited: Geoff Hayes on 14 Jun 2018
Check this out, might be helpful. https://youtu.be/sE3NkH1m24w%20 using MATLAB to run (ANSYS) APDL macro code

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!