Have switch language input method but can't type chinese in MATLAB in ubuntu20.04?

13 views (last 30 days)
When I switch the Chinese language mode input in MATLAB editor or matlab live script, I can't input/type Chinese, it's always English letters, Even though I have successfully switched to Chinese input mode (shown by the red circle in the upper right corner)? how to solve it?
In contrary,In other third-party applications (vscode, vim, gedit,etc.), I can switch the language input mode normally, and I can input Chinese normally.
During this period, I have tried reinstalling different Chinese input methods, restarting the system and MATLAB, and still the same result, the only thing I can't do is to input Chinese in the MATLAB environment.
Here is my current language input method configuration,for reference only.
my Env:
Related Issue

Accepted Answer

cui,xingxing on 7 Dec 2023
Edited: cui,xingxing on 3 Jan 2024
Mixing non-English languages can be more or less distracting and a waste of energy, and it's better for communication to switch to an international language, so I'm sticking to English here and in the follow-up process.
------------------------------------------Updating the dividing line-----------------------------------------------
Matlab R2024a Prerelease is OK.

More Answers (0)


Find more on Programming in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!