Clear Filters
Clear Filters

Error in opening MATLAB device file for LED trigger source.

15 views (last 30 days)
Hi, I am using the 'MATLAB support package for Raspberry Pi hardware' using MATLAB 2023a. I have installed all the necessary files on the Pi. I began following the tutorial here:
I got to the first step, ran the code
rpi = raspi('IP Address','username','password');
and was met with the following error (Practice_1 is the name of the script):
Error using Practice_1
Cannot open the device file for LED trigger source.
Any help please? I followed the tutorials accurately on the MathWorks website
  6 Comments
Syed Hadi
Syed Hadi on 26 Apr 2023
Hi, no I haven't got any response, I'm in contact with MathWorks about this, so I'll update this thread once we come to a solution.
Atakan Aral Ormanci
Atakan Aral Ormanci on 27 Apr 2023
I am getting the same error, i have checked the /sys/class/leds directory, it doesn't have led0 led1 led2. This might be causing the problem, i believe it has a function that when matlab is connected to RPi, it uses the leds, but in the connection phase, becouse it doesn't have the led0 activation command in the directory, it doesn't allow the connection.
But its just a guess.

Sign in to comment.

Accepted Answer

Syed Hadi
Syed Hadi on 9 May 2023
Edited: Syed Hadi on 9 May 2023
Hi guys,
I've been in contact with MathWorks support and we've solved this issue.
Basically, if you follow the link below:
You can see a list of OS for Raspberry Pi. MATLAB doesn't support the latest versions of the OS.
What you need to do is follow the link below:
And download the file named "2022-09-22-raspios-bullseye-armhf.img.xz".
Then, you can install the OS onto your SD Card using the normal method.
I used balenaEtcher to decompress and flash the OS onto the SD card.
The development team are now aware of this issue and will look into fixing it for future OS.
Hope this helps.
  2 Comments
Beryl Wicaksono
Beryl Wicaksono on 5 Jun 2023
Hi Syed Hadi,
are you facing ssh certificate issue after installing 2022-09-22-raspios-bullseye-armhf.img.xz? How do you resolve it?
Thanks
Prasanth Sunkara
Prasanth Sunkara on 11 Sep 2023
In my opinion using the official Raspberry Pi Imager tool is a better way to setup an image.
https://www.raspberrypi.com/documentation/computers/getting-started.html#using-raspberry-pi-imager
Please ensure you have enabled SSH and assigned proper hostname and user credentials. You may optionally enter the WiFi details as well.
There is an option in the Raspberry Pi imager tool to flash images from your PC too. Towards the end the list

Sign in to comment.

More Answers (2)

MathWorks MATLAB Hardware Team
Moved: Walter Roberson on 8 May 2023
Hi All,
Follow these steps to resolve the issue,
  • Open Raspberry Pi terminal and execute
  • $ cd /opt/MATLAB/
  • $ sudo pkill mwUnifiedSrvr
  • $ sudo rm -rf *
  • Download and extract following zip files
  • In MATLAB, change your working directory to the above extracted files
  • Run >> applyPath.m file
  • Create a raspi object in matlab
  • >> r = raspi("myAddress",'pi','raspberry');
Thanks,
MathWorks
MATLAB Hardware Team
  3 Comments

Sign in to comment.


Sandin Taci
Sandin Taci on 4 May 2023
Hey @Syed Hadi, try "raspberrypi instead of "raspi":
rpi = raspberrypi('IP Address','username','password')
  3 Comments
Sandin Taci
Sandin Taci on 4 May 2023
Can you go through these steps again, I guess you skipped a step. Your hardware tab in the Simulink model does not look customized.
https://www.mathworks.com/help/supportpkg/raspberrypi/ref/getting-started-with-raspberry-pi-hardware.html
Atakan Aral Ormanci
Atakan Aral Ormanci on 4 May 2023
Edited: Atakan Aral Ormanci on 4 May 2023
i just did the steps again and then i realised the problem is with the led.
i then tried to control a servo and it worked.

Sign in to comment.

Categories

Find more on MATLAB Support Package for Raspberry Pi Hardware in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!