MATLAB Answers

Ming
0

MATLAB 2014a cannot enable parpool

Asked by Ming
on 12 Jun 2014
Latest activity Commented on by Sean de Wolski
on 23 Jun 2014
Hi, I tried to enable parpool in MATLAB 2014a, it gives following message Error using parpool (line 99) The operation must modify one or more Settings files for these levels: factory, user, but you do not have write permission on these levels: user.
Error in parallel.internal.ui.PoolHelper.startPool (line 11) parpool();
I have all permissions, I tried to uninstall and install again, but after one or two days, this problem come out again

  4 Comments

Show 1 older comment
Ming
on 15 Jun 2014
Hi, Elwin
I am runing windows 7 sp1 x64 with all patches installed up-to-date. I am runing on my own PC, directly in the Administrator account, I have all permissions to run and change anything. The matlab is installed at C:\Program Files\MATLAB\R2014a I tried your suggestions, but it still doesn't work, unless I reinstall matlab, but 2, 3 days later this problem will appear again.
Someone post exact same problem in April:
Hi Ming,
Thanks for the info. When it is not working, please can you try the following code and reply with the results? (The code won't fix the problem, but might help to diagnose the issue.)
s = Settings;
s.parallel
s.parallel.addNode('test')
s.parallel.test.addKey('testKey')
s.parallel.test.isSet('testKey')
s.parallel.removeNode('test')
Thanks,
Elwin
Ming
on 16 Jun 2014
Hi,
Thank you for your replying, here are the results
s = Settings;
s.parallel
s.parallel.addNode('test')
s.parallel.test.addKey('testKey')
s.parallel.test.isSet('testKey')
s.parallel.removeNode('test')
ans =
Settings with no properties.
ans =
0

Sign in to comment.

1 Answer

Answer by Elwin Chan on 23 Jun 2014
 Accepted Answer

I debugged Ming's MATLAB installation, and the problem was that there was a 3rd party MATLAB toolbox installed that contained a file called assert.m which was higher up on the MATLAB search path than the built-in MATLAB function. This was causing MATLAB's built-in assert function to be shadowed, and caused the error.
You can see which assert function will used by calling
which -all assert
You want built-in (L:\Bparallel\matlab\toolbox\matlab\lang\assert) to be the first one on the list. If it is not the first on on the list, then you should re-arrange your path using MATLAB's path tool.

  2 Comments

Ming
on 23 Jun 2014
Thank you again Elwin, the MATLAB is now running fine.
I've seen uses' asserts break lots of things; it's probably the most shadowed function I've seen.

Sign in to comment.