Connecting simElectronic blocks -- get red dotted line

53 views (last 30 days)
Let me say up front - I'm a newbie.
When I connect many components in my circuit (e.g. resistor), instead of a solid black line, I get a red dotted line and the simulator tells me my components are unconnected.
What am I doing wrong?

Answers (6)

Kaustubha Govind
Kaustubha Govind on 31 Jul 2011
You are making connections between components that are not allowed to be connected directly. The documentation linked in the above answer will have more information.
Walter Roberson
Walter Roberson on 23 Sep 2019
Adil Abdul Qayyum: we do not make any requirement here in Mathworks Answers that every question must be answered with a quotation of the material or at least a link to a primary source. It is common that people ask questions that have already been answered, and it is acceptable that the volunteers reply with a link to where the material was already explained.
It is true that the link in that other Answer no longer leads to live documentation, but it did when Kaustubha posted her response in 2011. We do not make any requirement here in Mathworks Answers that everyone who posts a documentation link must chase through the links and update them as the target material moves. You could consider using Internet Archive's "Wayback Machine" to see previous versions of that documentation at the link.
Meanwhile, I did a brief search and updated the other Answer with two links to relevant material. You can look there to see it; I do not need to quote it here.

Sign in to comment.

Arnaud Miege
Arnaud Miege on 1 Aug 2011
You can't directly connect SimElectronics blocks to SimPowerSystems blocks. Have a look at these various threads and questions on the same topic:

Stephen on 31 Jul 2011
Thanks Kaustubha.
However, the "Interfacing the Electrical Circuit with Other Simulink Blocks" section (that you referenced in the link you provided) mentions that there is a problem when you connect > (angle Simulink) ports with square SimPowerSystems ports. I have a problem connecting square ports to square ports. Is the problem that I am connecting a resistor from SimElectronics to a linear transformer from SimPower systems? If so, can connect components from the two different Simulink products, and how?

geokim on 9 Jan 2012
hello,I've read all these articles on how to connect blocks from different libraries,but stil I haven't found any solution.My problem is connecting a PMW converter (from SimPowerSystems) to the gate of an n-channel IGBT (from SimElectonics ).

Sign in to comment.

Mark Fanslow
Mark Fanslow on 27 Jul 2016
I opened the power_breaker example from the SimPowerSystems library and tried to connect a voltage Measurement block across a resistor. When I tried to connect by dragging a connection from the Voltage measurement block to the resistor node I got the dotted red lines, no connection. I tried again by deleting the lines connecting the resistor nodes to the circuit and putting the voltage measurement block in place of the resistor - Successful black connections - I then reconnected the resistor in parallel with the voltage measurement block - Successful black line connections - go figure.

sharanu prasad posti
sharanu prasad posti on 24 Nov 2020
Try adding (ps-simulink converter) or (simulink-ps converter).
The components you are trying to connect maybe are from different library. so try the above method

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!