Hardware Support

NI-SCOPE Support from Instrument Control Toolbox

Control and acquire data from National Instruments NI-SCOPE devices.


National Instruments manufactures high-speed digitizers and oscilloscopes that use the NI-SCOPE driver. You can use MATLAB® together with Instrument Control Toolbox™ as your single software environment to configure, control, acquire, and analyze data from these instruments. The toolbox supports NI-SCOPE devices using NI-SCOPE driver version 3.6 or higher.

Once data is in MATLAB, you can analyze and visualize that data for tasks such as signal processing, statistical analysis, digital filtering, and curve fitting. You can also create graphical interfaces for collecting and analyzing your data and automating tests.

Consult the table for the list of NI-SCOPE devices supported by the latest release of Instrument Control Toolbox.

Supported Hardware

Bus Product Name NI Driver Type
 AT AT-5102 NI-SCOPE
 PCI PCI-5102 NI-SCOPE
  PCI-5105 NI-SCOPE
  PCI-5112 NI-SCOPE
  PCI-5114 NI-SCOPE
  PCI-5122 NI-SCOPE
  PCI-5124 NI-SCOPE
  PCI-5142 NI-SCOPE
  PCI-5152 NI-SCOPE
  PCI-5153 NI-SCOPE
  PCI-5154 NI-SCOPE
  PCI-5911 NI-SCOPE
  PCI-5922 NI-SCOPE
 PCMCIA PCMCIA-5102 NI-SCOPE
 PXI PXI-5102 NI-SCOPE
  PXI-5105 NI-SCOPE
  PXI-5112 NI-SCOPE
  PXI-5114 NI-SCOPE
  PXI-5122 NI-SCOPE
  PXI-5124 NI-SCOPE
  PXI-5142 NI-SCOPE
  PXI-5152 NI-SCOPE
  PXI-5153 NI-SCOPE
  PXI-5154 NI-SCOPE
  PXI-5620 NI-SCOPE
  PXI-5621 NI-SCOPE
  PXI-5900 NI-SCOPE
  PXI-5922 NI-SCOPE
 PXI-Express PXIe-5122 NI-SCOPE
  PXIe-5185 NI-SCOPE
  PXIe-5186 NI-SCOPE
  PXIe-5622 NI-SCOPE
  PXIe-5105 NI-SCOPE
  PXIe-5114 NI-SCOPE
 USB USB-5102 NI-SCOPE
  USB-5132 NI-SCOPE
  USB-5133 NI-SCOPE

Related Hardware Support Views: Aerospace and Defense, Communication Infrastructure, Consumer Electronics, Instrument Control Toolbox, Instrumentation, MathWorks Supported, MATLAB Product Family, National Instruments, Support Package Installer Enabled, Test and Measurement, USB

Ready to install?

Before installing the support package, confirm you have the correct setup. View system requirements and installation options.

Get support package

Software

Required

Recommended

Support Package

Required

Support Package Installer installs this support package and all required third-party software. To start the installer, go to the MATLAB toolstrip and click Add-Ons > Get Hardware Support Packages. For more information, read the documentation.

Get support package

Hardware

Required

Any National Instruments oscilloscope that uses NI-SCOPE driver software

Don't see the hardware you're looking for?