Hardware Support

NI-FGEN Support from Instrument Control Toolbox

Control National Instruments NI-FGEN devices and create your own arbitrary waveforms using MATLAB.


National Instruments manufactures arbitrary waveform and function generators that use the NI-FGEN driver. You can use MATLAB® together with Instrument Control Toolbox™ as your single software environment to configure, control, and create waveforms with these instruments. The toolbox supports NI-FGEN devices using NI-FGEN driver version 2.7.2 or higher.

With MATLAB, you can analyze and visualize data for tasks such as signal processing, statistical analysis, digital filtering, and curve fitting. You can also create graphical interfaces for collecting and analyzing your data and automating tests.

Consult the table for the list of NI-FGEN devices supported by the latest release of Instrument Control Toolbox.

Supported Hardware

Bus Product Name NI Driver Type
 PCI PCI-5401 NI-FGEN
  PCI-5402 NI-FGEN
  PCI-5406 NI-FGEN
  PCI-5411 NI-FGEN
  PCI-5412 NI-FGEN
  PCI-5421 NI-FGEN
  PCI-5431 NI-FGEN
 PXI PXI-5401 NI-FGEN
  PXI-5402 NI-FGEN
  PXI-5404 NI-FGEN
  PXI-5406 NI-FGEN
  PXI-5411 NI-FGEN
  PXI-5412 NI-FGEN
  PXI-5421 NI-FGEN
  PXI-5422 NI-FGEN
  PXI-5431 NI-FGEN
  PXI-5441 NI-FGEN
 PXI-Express PXIe-5413 NI-FGEN
  PXIe-5423 NI-FGEN
  PXIe-5433 NI-FGEN
  PXIe-5442 NI-FGEN
  PXIe-5450 NI-FGEN
  PXIe-5451 NI-FGEN

Related Hardware Support Views: Aerospace and Defense, Communication Infrastructure, Consumer Electronics, Instrument Control Toolbox, Instrumentation, MathWorks Supported, MATLAB Product Family, National Instruments, Support Package Installer Enabled, Test and Measurement

Ready to install?

Before installing the support package, confirm you have the correct setup. View system requirements and installation options.

Get support package

Software

Required

Recommended

Support Package

Required

Support Package Installer installs this support package and all required third-party software. To start the installer, go to the MATLAB toolstrip and click Add-Ons > Get Hardware Support Packages. For more information, read the documentation.

Get support package

Hardware

Required

Any National Instruments function generator that uses NI-FGEN driver software

Software

Required

All required third-party software is installed by the Support Package Installer.

Don't see the hardware you're looking for?