File Exchange

image thumbnail

Communications Toolbox Support Package for Analog Devices ADALM-Pluto Radio

Prototype and test software-defined radio (SDR) systems using ADALM-PLUTO with MATLAB and Simulink

286 Downloads

Updated 15 Nov 2019

Editor's Note:

This support package is currently unable to download third-party software for MATLAB R2017a and earlier versions. For details and workaround, see this Bug Report.

MATLAB R2017b and later versions are unaffected.

Communications System Toolbox™ Support Package for Analog Devices® ADALM- Pluto Radio lets you use MATLAB® and Simulink® to design and verify practical wireless systems. Using this support package, you can use ADALM-Pluto Radio as a standalone peripheral for live RF data I/O using MATLAB functions or Simulink blocks. This lets you quickly test your transmitter and receiver designs under real-world conditions.

This support package is functional for R2017a and beyond.

Comments and Ratings (40)

zhao li

Hello, this installer does not work.
After installing and running the 'manage' dialog, I get the following error:
The libiio installation directory was not found. Try reinstalling the
support package.
This package has some sort of issue installing the libiio library.
I am running matlab R2019b (as administrator). I can successfuly communicate with the adalm-pluto outside of matlab using ssh, sdr#, and windows explorer.
Windows 7 sp:1, 64 bit
Thank you,
Aaron

wang wen

Jack Ma

没办法下载

Jack Ma

感觉这个东西有好多问题

Jack Ma

踩着梯子也下载不了 好多问题

Yiwei Su

基带佐NB

xinyu zhao

要挂vpn

Pan Eric

Using VPN in China if you are dealing with "Cannot download ... PlutoSDR Firmware."

Ethem

As of today, all download errors have been fixed. Please note that for R2017a and earlier versions, you must follow the instructions given in the bug report referenced in the Editor's Note.
If you are still having installation problems, please contact MathWorks Support: https://www.mathworks.com/support/contact_us.html

doesn't work on R2017b

LIU-Yinyi

I found the solution!! Work well on Mac OSX 10.14 (both R2018b and R2019a).
First, make sure you install the PlutoSDR Driver for Mac (HoRNDIS);
Secondly, install the support package, need proxy and patience (oh it took me about nine hours to wait the download done).

Work well now !!!
I recommend that matlab staff should update the details of the installation procedure.

LIU-Yinyi

Cannot work on Mac OSX 10.14. Unable to connect.

Wendy Gao

It also does not work for 2018a and 2019a.

rongxin wan

"无法下载第三方软件:PlutoSDR Firmware"怎么整,要挂VPN🐴

jiang chen

Do F

Menghan Lin

For most people who get error when installing this package, here are my advice:
1. Run by Administrator in Windows
2. Use VPN if you are in China.

yi zheng

下载不了,第三方包下载错误。该怎么办

jbkohn

Is anyone using this toolbox on Mac, or have similar issues with the following?: The support package indicates it installs successfully; however, MATLAB crashes when trying to run the examples for this toolbox, and also when trying to complete the hardware setup through the Add On Manager. I am using a Macbook Pro mid 2010 with OS 10.13.6.

DI PAN

我下载不了

oh cant download getting error; pls what should i do

Can't download despite setting proxy settings

Igor Sedov

Failed to download the third-party software:
Library for interfacing with IIO devices

alex wang

cant download getting error;
Download Error
2017b also

chris Daman

cant download getting error;
Download Error

There was a problem downloading the third-party software. To resolve this issue, contact Technical Support

Adeel

Hos Rah

l f

MATLAB Release Compatibility
Created with R2017a
Compatible with R2017a to R2019b
Platform Compatibility
Windows macOS Linux