File Exchange

image thumbnail

Embedded Coder Support Package for AUTOSAR Standard

Develop AUTOSAR software components for automotive systems.

131 Downloads

Updated 22 Aug 2019

Embedded Coder® Support Package for AUTOSAR Standard provides additional AUTOSAR support to Embedded Coder. You can model AUTOSAR elements and generate ARXML and AUTOSAR-compatible C code from a Simulink® model. Verify AUTOSAR generated code using software- and processor-in-the-loop simulations.

This support package is provided for MATLAB releases R2014b through R2018b.

Beginning in R2019a, Embedded Coder® Support Package for AUTOSAR Standard is replaced by the AUTOSAR Blockset product (https://www.mathworks.com/products/autosar.html), which requires MATLAB and Simulink. To develop and simulate AUTOSAR models, you install AUTOSAR Blockset. Embedded Coder is required to generate AUTOSAR C/C++ code and XML component descriptions for AUTOSAR Classic and Adaptive Platforms.

If you have download or installation issues, please contact Technical Support: www.mathworks.com/contact_ts.

Comments and Ratings (25)

deng liu

How to install?

fengchao fu

Marco Lee

xu ding

han sam

Yongzhe Chu

han sam

yushun an

The features from Embedded Coder® Support Package for AUTOSAR Standard is transitioned to new AUTOSAR Blockset (https://www.mathworks.com/products/autosar.html). It is available with MATLAB and Simulink for model simulation. Embedded Coder is required to generate AUTOSAR C/C++ code and XML component descriptions for AUTOSAR Classic and Adaptive Platforms.

It failed to install, but I kept trying until it eventually installed. It took about 8 times.

cleven cai

download error ...

Unable to install this package in 2016b

Unable to install this package in 2018b...
Download Error

There was a problem downloading the support package. To resolve this issue, see this MATLAB Answer
The 'MATLAB Answer' link does not work either.

Is it possible to install this support package for Autosar in Matlab Version 2018b? I´m getting alway error while I try to install

Liu Peng

Gu Shizhang

Lin Chen

dfsg

MATLAB Release Compatibility
Created with R2014b
Compatible with R2014b to R2018b
Platform Compatibility
Windows macOS Linux