Clear Filters
Clear Filters

how to solve roadrunner getting stuck loading project?

86 views (last 30 days)
Massimo
Massimo on 22 May 2024 at 9:52
Answered: Simar on 13 Jun 2024 at 9:34
Hi, i am trying to run Roadrunner R2024a.
I have tried running it both on a Ubuntu 22.04, and on a docker of a Ubuntu 20.04, in both situations i managed to solve all issues up to executing the program and all the way to the project selection screen, including setting correctly the license.
Both setup get stuck trying to load the project after the project selection screen, with the application window not being update at all. The test on the Ubuntu 20.04 keeps the CPU running at 100% but never terminates and keeps printing:
WARNING: Qt message: QXcbConnection: XCB error: 128 (Unknown), sequence: 1330, resource id: 56623163, major code: 130 (Unknown), minor code: 3
I tried running the program under starce looking for trivial issues but i have not found any.
My machine has 32 gb memory, 8 gb video ram, i9 processor. The program never uses more than 5% ram.
Is there a way to solve this issue?

Answers (1)

Simar
Simar on 13 Jun 2024 at 9:34
Hi Massimo,
Running Roadrunner, especially a version as recent as R2024a, on Linux platforms like Ubuntu can sometimes present challenges due to the differences in library versions, graphics drivers, and how certain dependencies are managed.
The error message encountered, particularly related to “QXcbConnection” and “XCB", suggests an issue with the Qt framework's interaction with the X server, which is a common component in Linux systems for managing graphical interfaces. Below are workarounds worth considering for troubleshooting and potentially solving the issue:
1. Check Graphics Drivers: Ensure graphics drivers are up to date, especially as mentioned using an i9 processor with 8 GB of video RAM. For NVIDIA GPUs, use the NVIDIA proprietary drivers rather than Nouveau. For NVIDIA, check driver version and update it using:
ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
Reboot after installing new drivers to ensure changes take effect.
2. Install Missing Libraries: Missing libraries can cause issues. Ensure to have all the necessary Qt and X11 libraries installed. Install common ones using:
sudo apt-get install libqt5widgets5 libqt5network5 libqt5gui5 libqt5core5a libqt5dbus5 libx11-xcb1
3. Use Xorg Instead of Wayland: If running on Ubuntu 20.04 or 22.04, the system might be using Wayland by default. Try switching to Xorg if have not already, as some applications have compatibility issues with Wayland. Select Xorg on the login screen by clicking the gear icon before logging in.
4. Running Inside Docker: Running GUI applications inside Docker requires setting up X11 forwarding or using tools like x11docker. Given error and high CPU usage without termination, it might be more challenging to debug inside Docker. Focus on getting the application running natively on Ubuntu first.
Ensure system is fully updated (sudo apt-get update && sudo apt-get upgrade)and rebooted after making significant changes, especially drivers or critical system libraries. Sometimes, issues resolve after system restart, ensuring all components are correctly loaded.
Hope it helps!
Best Regards,
Simar

Tags

Products


Release

R2024a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!