MATLAB Answers

csv upload fails "...contains invalid location fields"

2 views (last 30 days)
Hey, (sorry about my english)
since yesterday I got , during CSV Upload, the Error message : "The file was not uploaded because it contains invalid location fields"
My investigation, what is wrong with the csv-file, was not helpfull, I found nothing (for me) obvious wrong. The upload procedure I have done a lot of times in the past, w/o any issue!!! but now ?????
(I double checked the file with Excel, notepad++, textpad... deleted rows in the file, added manualy some field values in an row,.... reduced a dummy file to only 10 rows....
==> some times it worked, sometimes not.)
What is the KEY Reason for this error massage? a certain coding? after checking since hours, trying different minor/major changes, I have no glue what is wrong.
I need a simple hint in what direction or on what "Point (?)" I have to check?!?!
The File I wants to upload is from TS downloaded -> deleted some (faulty) rows -> upload again.
The Upload procedure I make 1000 of times in the past.... but since yesterday, I was not lucky. :-(((
cheers & thanks in advance


Show 2 older comments
Yam Schuster
Yam Schuster on 17 Feb 2020
@Vinod: thanks for your reply: This is also the idea I have had, if it would help, I had done this directly,
My recent investigations on my side during today (last several hours with testing) is:
It is regardless which file (older than today) with which content I try to upload: IT DONT WORK, grrr
This means: a csv file (I take from my 100reds backups) which worked in the past (I mean which was already uploaded in the past): Now/today : the upload is not working! all the time the msg "..invalid location fields"
the only thing which works: when I now (Today) download a feed in .csv format, then I can upload it again (to my newly created test-dummy channel) .
My (strong) guess (meanwhile) is : maybe something wrong on TS side.
I´m wondering that a Google search with "error message Thingspeak & invalid location fields" find ABSOLUTELY nothing helpfull. And what the hell ;-) is a location field? The .csv have only "lat" & "lon", and this can be empty!?!
Only one similar issue I found is regarding an UTC time Issue , but tests with UTC ~> changed to CET (in my file / any file) was not successfull.
For further Help: I copied some lines from a channel in one Test csv File
  1. created new file with 8 entires in "feeds Test1 #UL-works.csv"
  2. append 3 entries to this 1st file, result see --> "feeds Test2 #UL-worksNOT.csv" <-- is not uploading
  3. changed 1 Empty field (entry ID 10 / field3) --> "feeds Test3 #UL-worksAgain.csv" from empty to "11" <-- now it works ???
Is it a coincidence(?) which value can be empty or not?
Annother Test result was: a Value in an cell was "90" <-- this dont work, when I changed it from "90" to "89" then the upload works. (Grrr : only values less then 90 are alowed ?? ;;;;;-))) but this was valid only in the column of field2! ;-)) I get mad during this ;-)) tell me: is there a rule???????
The Issue I have: - I want to upload/update a channel with several 1,000 rows which I downloaded yesterday, then deleted several rows (faulty useless mesurements, generated during tests), and then update the channel with the modificated csv file {as practiced several times in the past with several channels} w/o any issue.
Thanks in advance
P.S. maybe tomorrow , when the Upload Routine on ThingSpeak side was changed, again it works, I belive in miracels ;-)))
Yam Schuster
Yam Schuster on 17 Feb 2020
@Joachim Keinert: thanks for your hint, so I´m not 'allone' ;-)
and @all: I of course checked the 'RTMF' ;-) regarding the csv files, and of course checked the coding thing regarding UTF-8 ..... ;-))
thanks in advance for showing the direction for my further investigations.
Jimi Rex Pacete
Jimi Rex Pacete on 18 Feb 2020
I used to export the data log on to the channel then reimport. But now I can't. My issue is still unresolved :(

Sign in to comment.

Accepted Answer

Christopher Stapels
Christopher Stapels on 18 Feb 2020
There were two recent changes to csv upload.
Position validation: the Latitude must be from -90 to +90, and Longitude from -180 to 180. Also, the time format should be ISO 8601, like this example: 2020-05-15T20:03:48-05:00
If your file continues to fail, can you share a few rows of the file that are failing?


Show 1 older comment
Yam Schuster
Yam Schuster on 18 Feb 2020
Christopher, That's me (Rahoul) with my newest dummy-account for testing the Upload issue.
But I was not logged on (something is strange today on Thingspeak ;-)) ????
Christopher Stapels
Christopher Stapels on 18 Feb 2020
Ill test your file and let you know when I have more information.
Yam Schuster
Yam Schuster on 18 Feb 2020
you are welcome ;-)) thanks in advance for your effort!!!

Sign in to comment.

More Answers (1)

Yam Schuster
Yam Schuster on 18 Feb 2020
@Christopher. my recent changes / trials:
  • filled the lat&lon fileds w/ dummy values --> still not working
  • played arround with the date Time:
  • "2019-11-07 14:32:12 UTC" ~~> "2019-11-07T14:32:12"
  • "2019-11-07 14:32:12 UTC" ~~> "2019-11-07T14:32:12+0"
  • "2019-11-07 14:32:12 UTC" ~~> "2019-11-07T14:32:12+000"
  • "2019-11-07 14:32:12 UTC" ~~> "2019-11-07T14:32:12" same result: --> still not uploading
  • ---> there must be something regarding the values itself , but where and what?
See my 3 examples from yesterday: there I figured out : if changing only one certain value, this can be the show stopper. But why? I see no rule behind it.
cheers Joachim


Show 1 older comment
Yam Schuster
Yam Schuster on 19 Feb 2020
Christopher, This sounds good! Thanks for your effort and help!!!
(for me it´s good to know, that I was not completly incapable, to do a 'simple' upload ;-) and therefore I come after 2days to the conclusion: 'maybe' a bug on the other end of the line ;-)) )
So during the next days, I´ll try it again....
cheers Joachim
Vinod on 19 Feb 2020
Thank you for reporting the issue. It has been resolved.
Yam Schuster
Yam Schuster on 20 Feb 2020
Hey Vinod & Christopher,
thanks for your support. I tested it today, everything is fine again now. the Upload works again!!! Good Job!!!

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!