I have no 'Build Model' button on my Simulink model Toolbar.

43 views (last 30 days)
I have no 'Build Model' button on my Toolbar in my Simulink model. I looked it up, and found several solutions, all of which have not worked. I have the proper hardware installed, and I've tried Ctrl+ B. Ctrl+ B seemed to work, as all of the lights were green, and no errors showed up in the diagnostics, but still, my robot will not run. To give more insight, I am trying to build and code for the 'Tank Robot Control using VEXnet Gamepad' using your instructions, but when I made it to Task 3, where it requires you to select the 'Build Model' button, that was when I realized that the button was not there. I followed all of the instructions explicitly, and have even tried changing the batteries in my gamepad and charging the battery for the microcontroller. For whatever reason, even though my gamepad and microcontroller are synched, I cannot control the robot, even when they are connected through the USB A-male A-male cable.

Answers (1)

Sebastian Castro
Sebastian Castro on 12 Nov 2019
Do you have MATLAB Coder and Simulink Coder in your license? If you type in
>> ver
in MATLAB, do those toolboxes show up?
- Sebastian
  1 Comment
Palguna Gopireddy
Palguna Gopireddy on 20 Sep 2021
I have the same problem. I couldn't see the build model icon. I have the matlab coder and simulink coder

Sign in to comment.


Find more on Automotive Applications in Help Center and File Exchange



Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!