Configure Time Scope

Signal Display

Time Scope uses the Time span and Time display offset parameters to determine the time range. To change the signal display settings, select View > Configuration Properties to bring up the Configuration Properties dialog box. Then, modify the values for the Time span and Time display offset parameters on the Main tab. For example, if you set the Time span to 25 seconds, the scope displays 25 seconds’ worth of simulation data at a time. If you also set the Time display offset to 5 seconds, the scope displays values on the time axis from 5 to 30 seconds. The values on the time axis of the Time Scope display remain the same throughout simulation.

To communicate the simulation time that corresponds to the current display, the scope uses the Time units, Time offset, and Simulation time indicators on the scope window. The following figure highlights these and other important aspects of the Time Scope window.

Time Indicators

  • Minimum time-axis limit — The Time Scope sets the minimum time-axis limit using the value of the Time display offset parameter on the Main tab of the Configuration Properties dialog box. If you specify a vector of values for the Time display offset parameter, the scope uses the smallest of those values to set the minimum time-axis limit.

  • Maximum time-axis limit — The Time Scope sets the maximum time-axis limit by summing the value of Time display offset parameter with the value of the Time span parameter. If you specify a vector of values for the Time display offset parameter, the scope sets the maximum time-axis limit by summing the largest of those values with the value of the Time span parameter.

  • Time units — The units used to describe the time-axis. The Time Scope sets the time units using the value of the Time Units parameter on the Time tab of the Configuration Properties dialog box. By default, this parameter is set to Metric (based on Time Span) and displays in metric units such as milliseconds, microseconds, minutes, days, etc. You can change it to Seconds to always display the time-axis values in units of seconds. You can change it to None to not display any units on the time axis. When you set this parameter to None, then Time Scope shows only the word Time on the time axis.

    To hide both the word Time and the values on the time axis, set the Show time-axis labels parameter to None. To hide both the word Time and the values on the time axis in all displays, except the bottom ones in each column of displays, set this parameter to Bottom Displays Only. This behavior differs from the Simulink® Scope block, which always shows the values but never shows a label on the x-axis.

For more information, see Configure the Time Scope Properties.

Simulation Indicators

  • Simulation status — Provides the status of the model simulation. The status can be either of the following conditions:

    • Processing — Occurs after you run the step method and before you run the release method.

    • Stopped — Occurs after you construct the scope object and before you first run the step method. This status also occurs after you run the release method.

    The Simulation status is part of the status bar in the scope window. You can choose to hide or display the entire status bar. From the scope menu, select View > Status Bar.

  • Time offset — The Offset value helps you determine the simulation times for which the scope is displaying data. The value is always in the range 0OffsetSimulation time. If the time offset is 0, the Scope does not display the Offset status field. Add the Time offset to the fixed time span values on the time-axis to get the overall simulation time.

    For example, if you set the Time span to 20 seconds, and you see an Offset of 0 (secs) on the scope window. This value indicates that the scope is displaying data for the first 0 to 20 seconds of simulation time. If the Offset changes to 20 (secs), the scope displays data for simulation times from 20 seconds to 40 seconds. The scope continues to update the Offset value until the simulation is complete.

  • Simulation time — The amount of time that the Time Scope has spent processing the input. Every time you call the scope, the simulation time increases by the number of rows in the input signal divided by the sample rate, as given by the following formula: tsim=tsim1+length(0:length(xsine))1SampleRate. You can set the sample rate using the SampleRate property. For frame-based inputs, the displayed Simulation time is the time at the beginning of the frame.

    The Simulation time is part of the status bar in the Time Scope window. You can choose to hide or display the entire status bar. From the Time Scope menu, select View > Status Bar .

Axes Maximization

When the scope is in maximized axes mode, the following figure highlights the important indicators on the scope window.

To toggle this mode, in the scope menu, select View > Configuration Properties. In the Main pane, locate the Maximize axes parameter.

Specify whether to display the scope in maximized axes mode. In this mode, each of the axes is expanded to fit into the entire display. To conserve space, labels do not appear in each display. Instead, tick-mark values appear on top of the plotted data. You can select one of the following options:

  • Auto — In this mode, the axes appear maximized in all displays only if the Title and YLabel properties are empty for every display. If you enter any value in any display for either of these properties, the axes are not maximized.

  • On — In this mode, the axes appear maximized in all displays. Any values entered into the Title and YLabel properties are hidden.

  • Off — In this mode, none of the axes appear maximized.

The default setting is Auto.

Reduce Updates to Improve Performance

By default, the scope updates the displays periodically at a rate not exceeding 20 hertz. If you would like the scope to update on every simulation time step, you can disable the Reduce Updates to Improve Performance option. However, as a recommended practice, leave this option enabled because doing so can significantly improve the speed of the simulation.

In the Time Scope menu, select Playback > Reduce Updates to Improve Performance to clear the check box. Alternatively, use the Ctrl+R shortcut to toggle this setting. You can also set the ReduceUpdates property to false to disable this option.

Display Multiple Signals

Multi-Signal Input

You can configure the Time Scope to show multiple signals within the same display or on separate displays. By default, the signals appear as different-colored lines on the same display. The signals can have different dimensions, sample rates, and data types. Each signal can be either real or complex valued. You can set the number of input ports on the Time Scope in the following ways:

  • Set the NumInputPorts property. This property is nontunable, so you should set it before you run the scope.

  • Run the show method to open the scope window. In the scope menu, select File > Number of Input Ports.

  • Run the show method to open the scope window. In the scope menu, select View > Configuration Properties and set the Number of input ports on the Main tab.

An input signal may contain multiple channels, depending on its dimensions. Multiple channels of data always appear as different-colored lines on the same display.

Multiple Signal Names and Colors.  By default, if the input signal has multiple channels, the scope uses an index number to identify each channel of that signal. For example, a 2-channel signal would have the following default names in the channel legend: Channel 1, Channel 2. To show the legend, select View > Configuration Properties, click the Display tab, and select the Show Legend check box. If there are a total of seven input channels, the following legend appears in the display.

By default, the scope has a black axes background and chooses line colors for each channel in a manner similar to the Simulink Scope block. When the scope axes background is black, it assigns each channel of each input signal a line color in the order shown in the above figure.

If there are more than seven channels, then the scope repeats this order to assign line colors to the remaining channels. To choose line colors for each channel, change the axes background color to any color except black. To change the axes background color to white, select View > Style, click the Axes background color button (), and select white from the color palette. Run the simulation again. The following legend appears in the display. This figure shows the color order when the background is not black.

Multiple Displays

You can display multiple channels of data on different displays in the scope window. In the scope toolbar, select View > Layout, or select the Layout button ().

Note

The Layout menu item and button are not available when the scope is in snapshot mode.

You can tile the window into multiple displays. For example, if there are three inputs to the scope, you can display the signals in three separate displays. The layout grid shows a 4 by 4 grid, but you can select up to 16 by 16 by clicking and dragging within the layout grid.

When you use the Layout option to tile the window into multiple displays, the display highlighted in blue is referred to as the active display. The scope dialog boxes reference the active display.

Time Scope Measurement Panels

The Measurements panels are the five panels that appear to the right side of the Scope GUI.

Trace Selection Panel

When you use the scope to view multiple signals, the Trace Selection panel appears. Use this panel to select which signal to measure. To open the Trace Selection panel:

  • From the menu, select Tools > Measurements > Trace Selection.

  • Open a measurement panel.

Triggers Panel

What Is the Trigger Panel.  The Trigger panel defines a trigger event to synchronize simulation time with input signals. You can use trigger events to stabilize periodic signals such as a sine wave or capture non-periodic signals such as a pulse that occurs intermittently.

To open the Trigger panel:

  1. Open a Scope block window.

  2. On the toolbar, click the Triggers button .

  3. Run a simulation.

    Triangle trigger pointers indicate the trigger time and trigger level of an event. The marker color corresponds to the color of the source signal.

Main Pane.  Mode — Specify when the display updates.

  • Auto — Display data from the last trigger event. If no event occurs after one time span, display the last available data.

    Normal — Display data from the last trigger event. If no event occurs, the display remains blank.

  • Once — Display data from the last trigger event and freeze the display. If no event occurs, the display remains blank. Click the Rearm button to look for the next trigger event.

  • Off — Disable triggering.

Position (%) — Specify the position of the time pointer along the y-axis. You can also drag the time pointer to the left or right to adjust its position.

Source/Type and Levels/Timing Panes.  Source — Select a trigger signal. For magnitude and phase plots, select either the magnitude or the phase.

Type — Select the type of trigger.

Trigger TypeTrigger Parameters

Edge — Trigger when the signal crosses a threshold.

Polarity — Select the polarity for an edge-triggered signal.

  • Rising — Trigger when the signal is increasing.

  • Falling — Trigger when the signal value is decreasing.

  • Either — Trigger when the signal is increasing or decreasing.

Level — Enter a threshold value for an edge triggered signal. Auto level is 50%

Hysteresis — Enter a value for an edge-triggered signal. See Hysteresis of Trigger Signals

Pulse Width — Trigger when the signal crosses a low threshold and a high threshold twice within a specified time.

Polarity — Select the polarity for a pulse width-triggered signal.

  • Positive — Trigger on a positive-polarity pulse when the pulse crosses the low threshold for a second time.

  • Negative — Trigger on a negative-polarity pulse when the pulse crosses the high threshold for a second time.

  • Either — Trigger on both positive-polarity and negative-polarity pulses.

Note

A glitch-trigger is a special type of a pulse width-trigger. A glitch-Trigger occurs for a pulse or spike whose duration is less than a specified amount. You can implement a glitch trigger by using a pulse width-trigger and setting the Max Width parameter to a small value.

High — Enter a high value for a pulse width-triggered signal. Auto level is 90%.

Low — Enter a low value for a pulse width-triggered signal. Auto level is 10%.

Min Width — Enter the minimum pulse-width for a pulse width triggered signal. Pulse width is measured between the first and second crossings of the middle threshold.

Max Width — Enter the maximum pulse width for a pulse width triggered signal.

Transition — Trigger on the rising or falling edge of a signal that crosses the high and low levels within a specified time range.

Polarity — Select the polarity for a transition-triggered signal.

  • Rise Time — Trigger on an increasing signal when the signal crosses the high threshold.

  • Fall Time — Trigger on a decreasing signal when the signal crosses the low threshold.

  • Either — Trigger on an increasing or decreasing signal.

High — Enter a high value for a transition-triggered signal. Auto level is 90%.

Low — Enter a low value for a transition-triggered signal. Auto level is 10%.

Min Time — Enter a minimum time duration for a transition-triggered signal.

Max Time — Enter a maximum time duration for a transition-triggered signal.

Runt— Trigger when a signal crosses a low threshold or a high threshold twice within a specified time.

Polarity — Select the polarity for a runt-triggered signal.

  • Positive — Trigger on a positive-polarity pulse when the signal crosses the low threshold a second time, without crossing the high threshold.

  • Negative — Trigger on a negative-polarity pulse.

  • Either — Trigger on both positive-polarity and negative-polarity pulses.

High — Enter a high value for a runt-triggered signal. Auto level is 90%.

Low — Enter a low value for a runt-triggered signal. Auto level is 10%.

Min Width — Enter a minimum width for a runt-triggered signal. Pulse width is measured between the first and second crossing of a threshold.

Max Width — Enter a maximum pulse width for a runt-triggered signal.

Window — Trigger when a signal stays within or outside a region defined by the high and low thresholds for a specified time.

Polarity — Select the region for a window-triggered signal.

  • Inside — Trigger when a signal leaves a region between the low and high levels.

  • Outside — Trigger when a signal enters a region between the low and high levels.

  • Either — Trigger when a signal leaves or enters a region between the low and high levels.

High — Enter a high value for a window-triggered signal. Auto level is 90%.

Low — Enter a low value for a window-trigger signal. Auto level is 10%.

Min Time — Enter the minimum time duration for a window-triggered signal.

Max Time — Enter the maximum time duration for a window-triggered signal.

Timeout — Trigger when a signal stays above or below a threshold longer than a specified time

Polarity — Select the polarity for a timeout-triggered signal.

  • Rising — Trigger when the signal does not cross the threshold from below. For example, if you set Timeout to 7.50 seconds, the scope triggers 7.50 seconds after the signal crosses the threshold.

  • Falling — Trigger when the signal does not cross the threshold from above.

  • Either — Trigger when the signal does not cross the threshold from either direction

Level — Enter a threshold value for a timeout-triggered signal.

Hysteresis — Enter a value for a timeout-triggered signal. See Hysteresis of Trigger Signals.

Timeout — Enter a time duration for a timeout-triggered signal.

Alternatively, a trigger event can occur when the signal stays within the boundaries defined by the hysteresis for 7.50 seconds after the signal crosses the threshold.

Hysteresis of Trigger Signals.  Hysteresis (V) — Specify the hysteresis or noise reject value. This parameter is visible when you set Type to Edge or Timeout. If the signal jitters inside this range and briefly crosses the trigger level, the scope does not register an event. In the case of an edge trigger with rising polarity, the scope ignores the times that a signal crosses the trigger level within the hysteresis region.

You can reduce the hysteresis region size by decreasing the hysteresis value. In this example, if you set the hysteresis value to 0.07, the scope also considers the second rising edge to be a trigger event.

Delay/Holdoff Pane.  Offset the trigger position by a fixed delay, or set the minimum possible time between trigger events.

  • Delay (s) — Specify the fixed delay time by which to offset the trigger position. This parameter controls the amount of time the scope waits after a trigger event occurs before displaying a signal.

  • Holdoff (s) — Specify the minimum possible time between trigger events. This amount of time is used to suppress data acquisition after a valid trigger event has occurred. A trigger holdoff prevents repeated occurrences of a trigger from occurring during the relevant portion of a burst.

Cursor Measurements Panel

The Cursor Measurements panel displays screen cursors. The panel provides two types of cursors for measuring signals. Waveform cursors are vertical cursors that track along the signal. Screen cursors are both horizontal and vertical cursors that you can place anywhere in the display.

Note

If a data point in your signal has more than one value, the cursor measurement at that point is undefined and no cursor value is displayed.

Display screen cursors with signal times and values. To open the Cursor measurements panel:

  • From the menu, select Tools > Measurements > Cursor Measurements.

  • On the toolbar, click the Cursor Measurements button.

In the Settings pane, you can modify the type of screen cursors used for calculating measurements. When more than one signal is displayed, you can assign cursors to each trace individually.

  • Screen Cursors — Shows screen cursors (for spectrum and dual view only).

  • Horizontal — Shows horizontal screen cursors (for spectrum and dual view only).

  • Vertical — Shows vertical screen cursors (for spectrum and dual view only).

  • Waveform Cursors — Shows cursors that attach to the input signals (for spectrum and dual view only).

  • Lock Cursor Spacing — Locks the frequency difference between the two cursors.

  • Snap to Data — Positions the cursors on signal data points.

The Measurements pane displays time and value measurements.

  • 1 — View or modify the time or value at cursor number one (solid line cursor).

  • 2 — View or modify the time or value at cursor number two (dashed line cursor).

  • ΔT or ΔX — Shows the absolute value of the time (x-axis) difference between cursor number one and cursor number two.

  • ΔY — Shows the absolute value of the signal amplitude difference between cursor number one and cursor number two.

  • 1/ΔT or 1/ΔX — Shows the rate. The reciprocal of the absolute value of the difference in the times (x-axis) between cursor number one and cursor number two.

  • ΔY/ΔT or ΔY/ΔX — Shows the slope. The ratio of the absolute value of the difference in signal amplitudes between cursors to the absolute value of the difference in the times (x-axis) between cursors.

Signal Statistics Panel

Display signal statistics for the signal selected in the Trace Selection panel. To open the Signal Statistics panel:

  • From the menu, select Tools > Measurements > Signal Statistics.

  • On the toolbar, click the Signal Statistics button.

The statistics shown are:

  • Max — Maximum or largest value within the displayed portion of the input signal.

  • Min — Minimum or smallest value within the displayed portion of the input signal.

  • Peak to Peak — Difference between the maximum and minimum values within the displayed portion of the input signal.

  • Mean — Average or mean of all the values within the displayed portion of the input signal.

  • Median — Median value within the displayed portion of the input signal.

  • RMS — Root mean squared of the input signal.

When you use the zoom options in the scope, the Signal Statistics measurements automatically adjust to the time range shown in the display. In the scope toolbar, click the Zoom In or Zoom X button to constrict the x-axis range of the display, and the statistics shown reflect this time range. For example, you can zoom in on one pulse to make the Signal Statistics panel display information about only that particular pulse.

The Signal Statistics measurements are valid for any units of the input signal. The letter after the value associated with each measurement represents the appropriate International System of Units (SI) prefix, such as m for milli-. For example, if the input signal is measured in volts, an m next to a measurement value indicates that this value is in units of millivolts. The SI prefixes are shown in the following table:

Bilevel Measurements Panel

Bilevel Measurements.  Display information about signal transitions, overshoots, undershoots, and cycles. To open the Bilevel Measurements panel:

  • From the menu, select Tools > Measurements > Bilevel Measurements.

  • On the toolbar, click the Bilevel Measurements button.

Settings.  The Settings pane enables you to modify the properties used to calculate various measurements involving transitions, overshoots, undershoots, and cycles. You can modify the high-state level, low-state level, state-level tolerance, upper-reference level, mid-reference level, and lower-reference level.

  • Auto State Level — When this check box is selected, the Bilevel measurements panel detects the high- and low- state levels of a bilevel waveform. When this check box is cleared, you can enter in values for the high- and low- state levels manually.

    • High — Used to specify manually the value that denotes a positive polarity, or high-state level.

    • Low — Used to specify manually the value that denotes a negative polarity, or low-state level.

  • State Level Tolerance — Tolerance within which the initial and final levels of each transition must be within their respective state levels. This value is expressed as a percentage of the difference between the high- and low-state levels.

  • Upper Ref Level — Used to compute the end of the rise-time measurement or the start of the fall time measurement. This value is expressed as a percentage of the difference between the high- and low-state levels.

  • Mid Ref Level — Used to determine when a transition occurs. This value is expressed as a percentage of the difference between the high- and low- state levels. In the following figure, the mid-reference level is shown as the horizontal line, and its corresponding mid-reference level instant is shown as the vertical line.

  • Lower Ref Level — Used to compute the end of the fall-time measurement or the start of the rise-time measurement. This value is expressed as a percentage of the difference between the high- and low-state levels.

  • Settle Seek — The duration after the mid-reference level instant when each transition occurs used for computing a valid settling time. This value is equivalent to the input parameter, D, which you can set when you run the settlingtime function. The settling time is displayed in the Overshoots/Undershoots pane.

Transitions Pane.  Display calculated measurements associated with the input signal changing between its two possible state level values, high and low.

A positive-going transition, or rising edge, in a bilevel waveform is a transition from the low-state level to the high-state level. A positive-going transition has a slope value greater than zero. The following figure shows a positive-going transition.

When here is a plus sign (+) next to a text label, the measurement is a rising edge, a transition from a low-state level to a high-state level.

A negative-going transition, or falling edge, in a bilevel waveform is a transition from the high-state level to the low-state level. A negative-going transition has a slope value less than zero. The following figure shows a negative-going transition.

When there is a minus sign (–) next to a text label, the measurement is a falling edge, a transition from a high-state level to a low-state level.

The Transition measurements assume that the amplitude of the input signal is in units of volts. For the transition measurements to be valid, you must convert all input signals to volts.

  • High — The high-amplitude state level of the input signal over the duration of the Time Span parameter. You can set Time Span in the Main pane of the Visuals—Time Domain Properties dialog box.

  • Low — The low-amplitude state level of the input signal over the duration of the Time Span parameter. You can set Time Span in the Main pane of the Visuals—Time Domain Properties dialog box.

  • Amplitude — Difference in amplitude between the high-state level and the low-state level.

  • + Edges — Total number of positive-polarity, or rising, edges counted within the displayed portion of the input signal.

  • + Rise Time — Average amount of time required for each rising edge to cross from the lower-reference level to the upper-reference level.

  • + Slew Rate — Average slope of each rising-edge transition line within the upper- and lower-percent reference levels in the displayed portion of the input signal. The region in which the slew rate is calculated appears in gray in the following figure.

  • – Edges — Total number of negative-polarity or falling edges counted within the displayed portion of the input signal.

  • – Fall Time — Average amount of time required for each falling edge to cross from the upper-reference level to the lower-reference level.

  • – Slew Rate — Average slope of each falling edge transition line within the upper- and lower-percent reference levels in the displayed portion of the input signal.

Overshoots / Undershoots Pane.  The Overshoots/Undershoots pane displays calculated measurements involving the distortion and damping of the input signal. Overshoot and undershoot refer to the amount that a signal respectively exceeds and falls below its final steady-state value. Preshoot refers to the amount before a transition that a signal varies from its initial steady-state value.

This figure shows preshoot, overshoot, and undershoot for a rising-edge transition.

The next figure shows preshoot, overshoot, and undershoot for a falling-edge transition.

  • + Preshoot — Average lowest aberration in the region immediately preceding each rising transition.

  • + Overshoot — Average highest aberration in the region immediately following each rising transition.

  • + Undershoot — Average lowest aberration in the region immediately following each rising transition.

  • + Settling Time — Average time required for each rising edge to enter and remain within the tolerance of the high-state level for the remainder of the settle-seek duration. The settling time is the time after the mid-reference level instant when the signal crosses into and remains in the tolerance region around the high-state level. This crossing is illustrated in the following figure.

    You can modify the settle-seek duration parameter in the Settings pane.

  • – Preshoot — Average highest aberration in the region immediately preceding each falling transition.

  • – Overshoot — Average highest aberration in the region immediately following each falling transition.

  • – Undershoot — Average lowest aberration in the region immediately following each falling transition.

  • – Settling Time — Average time required for each falling edge to enter and remain within the tolerance of the low-state level for the remainder of the settle-seek duration. The settling time is the time after the mid-reference level instant when the signal crosses into and remains in the tolerance region around the low-state level. You can modify the settle-seek duration parameter in the Settings pane.

Cycles Pane.  The Cycles pane displays calculated measurements pertaining to repetitions or trends in the displayed portion of the input signal.

Properties to set:

  • Period — Average duration between adjacent edges of identical polarity within the displayed portion of the input signal. The Bilevel measurements panel calculates period as follows. It takes the difference between the mid-reference level instants of the initial transition of each positive-polarity pulse and the next positive-going transition. These mid-reference level instants appear as red dots in the following figure.

  • Frequency — Reciprocal of the average period. Whereas period is typically measured in some metric form of seconds, or seconds per cycle, frequency is typically measured in hertz or cycles per second.

  • + Pulses — Number of positive-polarity pulses counted.

  • + Width — Average duration between rising and falling edges of each positive-polarity pulse within the displayed portion of the input signal.

  • + Duty Cycle — Average ratio of pulse width to pulse period for each positive-polarity pulse within the displayed portion of the input signal.

  • – Pulses — Number of negative-polarity pulses counted.

  • – Width — Average duration between rising and falling edges of each negative-polarity pulse within the displayed portion of the input signal.

  • – Duty Cycle — Average ratio of pulse width to pulse period for each negative-polarity pulse within the displayed portion of the input signal.

When you use the zoom options in the Scope, the bilevel measurements automatically adjust to the time range shown in the display. In the Scope toolbar, click the Zoom In or Zoom X button to constrict the x-axis range of the display, and the statistics shown reflect this time range. For example, you can zoom in on one rising edge to make the Bilevel Measurements panel display information about only that particular rising edge. However, this feature does not apply to the High and Low measurements.

Peak Finder Panel

The Peak Finder panel displays the maxima, showing the x-axis values at which they occur. Peaks are defined as a local maximum where lower values are present on both sides of a peak. Endpoints are not considered peaks. This panel allows you to modify the settings for peak threshold, maximum number of peaks, and peak excursion.

  • From the menu, select Tools > Measurements > Peak Finder.

  • On the toolbar, click the Peak Finder button.

The Settings pane enables you to modify the parameters used to calculate the peak values within the displayed portion of the input signal. For more information on the algorithms this pane uses, see the findpeaks function reference.

Properties to set:

  • Peak Threshold — The level above which peaks are detected. This setting is equivalent to the MINPEAKHEIGHT parameter, which you can set when you run the findpeaks function.

  • Max Num of Peaks — The maximum number of peaks to show. The value you enter must be a scalar integer from 1 through 99. This setting is equivalent to the NPEAKS parameter, which you can set when you run the findpeaks function.

  • Min Peaks Distance — The minimum number of samples between adjacent peaks. This setting is equivalent to the MINPEAKDISTANCE parameter, which you can set when you run the findpeaks function.

  • Peak Excursion — The minimum height difference between a peak and its neighboring samples. Peak excursion is illustrated alongside peak threshold in the following figure.

    The peak threshold is a minimum value necessary for a sample value to be a peak. The peak excursion is the minimum difference between a peak sample and the samples to its left and right in the time domain. In the figure, the green vertical line illustrates the lesser of the two height differences between the labeled peak and its neighboring samples. This height difference must be greater than the Peak Excursion value for the labeled peak to be classified as a peak. Compare this setting to peak threshold, which is illustrated by the red horizontal line. The amplitude must be above this horizontal line for the labeled peak to be classified as a peak.

    The peak excursion setting is equivalent to the THRESHOLD parameter, which you can set when you run the findpeaks function.

  • Label Format — The coordinates to display next to the calculated peak values on the plot. To see peak values, you must first expand the Peaks pane and select the check boxes associated with individual peaks of interest. By default, both x-axis and y-axis values are displayed on the plot. Select which axes values you want to display next to each peak symbol on the display.

    • X+Y — Display both x-axis and y-axis values.

    • X — Display only x-axis values.

    • Y — Display only y-axis values.

The Peaks pane displays the largest calculated peak values. It also shows the coordinates at which the peaks occur, using the parameters you define in the Settings pane. You set the Max Num of Peaks parameter to specify the number of peaks shown in the list.

The numerical values displayed in the Value column are equivalent to the pks output argument returned when you run the findpeaks function. The numerical values displayed in the second column are similar to the locs output argument returned when you run the findpeaks function.

The Peak Finder displays the peak values in the Peaks pane. By default, the Peak Finder panel displays the largest calculated peak values in the Peaks pane in decreasing order of peak height.

Use the check boxes to control which peak values are shown on the display. By default, all check boxes are cleared and the Peak Finder panel hides all the peak values. To show or hide all the peak values on the display, use the check box in the top-left corner of the Peaks pane.

The Peaks are valid for any units of the input signal. The letter after the value associated with each measurement indicates the abbreviation for the appropriate International System of Units (SI) prefix, such as m for milli-. For example, if the input signal is measured in volts, an m next to a measurement value indicates that this value is in units of millivolts.

Style Dialog Box

Select View > Style or the Style button () in the dropdown below the Configuration Properties button to open the Style dialog box. In this dialog box, you can change the figure colors, background axes colors, foreground axes colors, and properties of lines in a display.

For more details about the properties, see Style Properties.

Axes Scaling Properties

The Axes Scaling Properties dialog box provides you with the ability to automatically zoom in on and zoom out of your data, and to scale the axes of the Time Scope. In the Time Scope menu, select Tools > Axes Scaling > Axes Scaling Properties to open this dialog box.

For more details about the properties, see Axes Scaling Properties.

Sources — Streaming Properties

The Sources – Streaming Properties dialog box lets you control the number of input signal samples that Time Scope holds in memory. In the Time Scope menu, select View > Data History Properties to open this dialog box.

Buffer length

Specify the size of the buffer that the scope holds in its memory cache. Memory is limited by available memory on your system. If your signal has M rows of data and N data points in each row, M x N is the number of data points per time step. Multiply this result by the number of time steps for your model to obtain the required buffer length. For example, if you have 10 rows of data with each row having 100 data points and your run will be 10 time steps, you should enter 10,000 (which is 10 x 100 x 10) as the buffer length.