Main Content

Requirements for Using Cloud Center

To use Cloud Center, you need:

  • A MathWorks Account.

  • Access to a MATLAB® license. If you want to use clusters, then also a MATLAB Parallel Server™ license.

  • An Amazon® Web Services (AWS®) account. You are responsible for the costs of all AWS services.

MATLAB Requirements

To use MATLAB in Cloud Center, you need:

  1. Access to a MATLAB license for a supported release that meets the following conditions:

    • Linked to a MathWorks Account.

    • Configured for cloud use. Individual and Campus-Wide licenses are already configured. For other license types, contact your administrator. You can identify your license type and administrator by viewing your MathWorks Account. Administrators can consult Administer Network Licenses.

Supported Releases for MATLAB

Consult the table for the currently supported MATLAB releases in Cloud Center.

Supported MATLAB Releases in Cloud Center
MATLAB R2022b
MATLAB R2022a
MATLAB R2021b

MATLAB Parallel Server Requirements

To use MATLAB Parallel Server, you need:

  1. Access to one of the last four releases of MATLAB and Parallel Computing Toolbox™.

    • To find out which release version you are using, start MATLAB and type 'ver'.

  2. Network access to cloud resources.

    • To check that you have network access to cloud resources, on the Home tab, select Parallel > Create and Manage Clusters, then in the Cluster Profile Manager select Test Cloud Connectivity.

    • For more information on server sockets accessed by the MATLAB client to connect with cloud resources, see Server Sockets Accessed by Client.

    • If you see an error and are unable to connect to the Cloud, contact the Installation Support team at support@mathworks.com. Try to provide the exact error message.

  3. A MATLAB Parallel Server license configured to use online licensing. For more details about online licensing, see Online Licensing for MATLAB Parallel Server.

  4. Only Linux-based Amazon Machine Images (AMI) are available via Cloud Center. MATLAB code is generally compatible between different operating systems, but you must use Linux-specific versions of executable files or programs. You cannot use Windows– or Mac– specific files, such as user-defined MEX-files, Excel spreadsheets, databases, third-party applications.

  5. Your AWS account needs access to EC2 instances in Amazon regions supported by Cloud Center. For more details on supported instances and regional availability, see Choose Supported EC2 Instance Machine Types.

Supported Releases for Clusters

Consult the table for the currently supported releases. After each new release, support for the oldest release will continue for at least 8 weeks to allow you to migrate to a supported release. For example, after R2019a was released, there was a migration period in which support for R2017a continued before support was removed.

Releases for Clusters in Cloud Center
MATLAB R2022b
MATLAB R2022a
MATLAB R2021b
MATLAB R2021a
MATLAB R2020b - Warns

Note

When you use Cloud Center, your cloud cluster will always run with the latest available Update version of MATLAB for that release. Updates are cumulative.

Cloud Center supports the twice-yearly general releases and update releases, and does not support prereleases. As newer versions of MATLAB become supported, the support for older versions will be removed in future releases.

Access Cloud Center

  1. To access Cloud Center, navigate in a Web browser to the website: https://cloudcenter.mathworks.com

  2. Sign in using your MathWorks® Account email address and password.

Related Topics