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Motivation for this workshop 

As the industry, technology and society make rapid progress, there is a growing need to teach the next 

generation of engineers ever more complex concepts and build intuition quickly, so that they can apply 

their knowledge to develop the technology of the future. This calls for hands-on and project-based learning 

via low-cost, easy to use hardware and software platforms, to make it easier and fun to teach, learn and 

test the engineering ideas. 

Simulink has long been the tool of choice of the industry (automotive, aerospace, electronics, etc.), since it 

provides a very user-friendly, collaborative and flexible environment for designing, simulating, testing and 

eventually implementing, complex, multi-domain systems and their control logic. 

 

Beginning Release 2012a, Simulink includes the capability to program low-cost hardware like LEGO 

Mindstorms NXT, Arduino, Raspberry Pi, and BeagleBoard.  This new capability enables students to develop 

and test a variety of controls, signal, image and video processing related applications, from within Simulink.  

 

This workshop is based on Simulink Support Package for LEGO MINDSTORMS NXT. Participants will have a 

chance to work through lab modules with examples of sound tone control and line following robots. They 

will gain practical hands-on experience in building high-level examples themselves. Additionally, 

participating faculty members would have a chance to understand the potential for use in the classroom 

with students. 

At the end of this workshop, the participant will be able to: 

1. design, simulate and test custom algorithms in Simulink 

2. implement these algorithms on low-cost embedded hardware such as LEGO MINDSTORMS NXT 

without writing any C-code 

3. see how easy it is to program low-cost hardware with Simulink 

Getting started 

If you are new to MATLAB, Simulink or Simulink Support Packages, take a look at the following introductory 

material to get started: 

a. To learn more about MATLAB and Simulink, check out interactive tutorials at: 

http://www.mathworks.com/academia/student_center/tutorials/ 

b. For the latest information about LEGO MINDSTORMS NXT Support from Simulink, see: 

http://www.mathworks.com/academia/lego-mindstorms-nxt-software/legomindstorms-

simulink.html 

c. Supported hardware for project based learning: 

http://www.mathworks.com/academia/hardware-resources/ 

  

http://www.mathworks.com/academia/student_center/tutorials/
http://www.mathworks.com/academia/lego-mindstorms-nxt-software/legomindstorms-simulink.html
http://www.mathworks.com/academia/lego-mindstorms-nxt-software/legomindstorms-simulink.html
http://www.mathworks.com/academia/hardware-resources/
http://www.mathworks.com/academia/hardware-resources/
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Introduction: How to use and work with this manual 

I1 Workshop run-through options 

While working through this manual, there are several entry points that you can 

choose from. 

 To understand manual notation we recommend reviewing intro sections I1 

and I1. 

 Depending on your Simulink skills level you might start with example problem P0.1, or with the first 

self-constructed model P1.2. 

 Reference material for frequently used tasks is listed in sections R1-R3 for your convenience. 

Start at the section relevant to your Simulink experience level: 
 

Section Topics Covered Level 
Recommended 
Experience 

I1, I2 Introduction, Resources Introductory None 

P0.1, P0.2, 
P0.3 

Getting familiar with Simulink Beginner None 

P1.1 Checking product installation Beginner Simulink 

P1.2, P1.3 System Design with Simulink Experienced Simulink, SSP for LEGO 

P1.4 Remote control of LEGO NXT via 
Bluetooth® 

Experienced Simulink, SSP for LEGO 

P2.1 – P2.4 Line Following Robot Advanced Simulink, SSP for LEGO 

P3 Further examples Advanced Simulink, SSP for LEGO 

*SSP = Simulink Support Package 

I2 Notation and formatting 

 All required information is formatted as standard text on white background. 

 Important information is highlighted with a grey background. 

 Buttons on the brick and in Simulink are displayed as such or bracketed, e.g., [OK] for the OK 

button or [Deploy to Hardware] (Figure 1). 

 Menu navigation in Simulink is shown as a sequence, e.g., MyFiles > 

SoftwareFiles > SoundTone1 > Run. 

 MATLAB code to be run / copied, is included in the document as below: 

xlabel('Time [sec]'); 

  

Figure 1: Simulink UI 
Button Example 
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Project 0: Getting familiar with Simulink 

P0.1 Simulink 

Simulink® is a block diagram environment for multi-domain simulation and Model-Based Design. It supports 

system-level design, simulation, automatic code generation, and continuous test and verification of 

embedded systems. Simulink provides a graphical editor, customizable block libraries, and solvers for 

modeling and simulating dynamic systems. It is integrated with MATLAB®, enabling you to incorporate 

MATLAB algorithms into models and export simulation results to MATLAB for further analysis. 

Key Features 

 Graphical editor for building and managing hierarchical block diagrams 

 Libraries of predefined blocks for modeling continuous-time and discrete-time systems 

 Simulation engine with fixed-step and variable-step ODE solvers 

 Scopes and data displays for viewing simulation results 

 Project and data management tools for managing model files and data 

 Model analysis tools for refining model architecture and increasing simulation speed 

 MATLAB Function block for importing MATLAB algorithms into models 

 Legacy Code Tool for importing C and C++ code into models 

With the help of code generation products like Simulink Coder and Embedded Coder, Simulink models can 

also be converted to C-code optimized for specific embedded platforms. 

P0.2 Simulink Library Browser and Simulink Model 

To get started with Simulink, launch the Simulink Library Browser. To 

do this, click on the Simulink Library Browser button on the Home 

Tab of MATLAB Desktop, or type simulink at the MATLAB 

command prompt. 

The Simulink Library Browser is a collection of high level blocks that 

you can use to create a block-diagram representation of the system 

you are trying to design. From a different perspective, these blocks 

allow you to access or generate, apply algorithms and visualize or 

save the processed data or information, which flows through the 

system. 

Once the Simulink Library Browser launches, you will see a window like Figure 3 below. Depending on the 

products included in the MATLAB installation, you will see some or all of the block libraries. In particular, 

we will work with the Simulink Support Package for LEGO MINDSTORMS NXT Hardware, which is 

highlighted below. 

A Simulink Model (Figure 4) represnts the high level design of a system or an algorithm. You can create 

models by dropping blocks from the Simulink Library. After that, you can run the simulation or deploy it to 

the hardware.  

Figure 2: Launch Simulink 
Library Browser 
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 Simulink Library Browser  [Open] an existing Simulink model 

 Simulink block libraries  [Create] a new model 

 Library blocks  [Search] for library blocks 

 

 

Figure 4: Simulink Model 

 Simulink Model Window  [Save] a Simulink model 

 Simulink model  [Run] Simulink model 

 [Open] the Simulink Library Browser  [Deploy] Simulink model to hardware 

 [Create] a new Simulink model   
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Figure 3: Simulink Library Browser 
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P0.3 Simulation with Simulink 

A Simulink model represents a high-level, graphical design of your algorithm or system. 

Say for example XYZ Automobiles is trying to design a new car. As you can imagine, a car is a complicated 

system with different mechanical, electrical and hydraulic components, whose interaction is controlled by 

intelligent computers running embedded code. Any mistakes in the design process can result in significant 

revenue loss for XYZ Automobiles. To avoid this, they will actually design a car and test a significant part of 

its performance in a computer simulation environment, before they even make it. 

The industry standard way to do this is by creating mathematical models of different components, and then 

simulating their interaction based on intelligent algorithms, that make sure that things behave in a nice 

way. This approach is becoming standard in almost all automotive, aerospace, defense and hi-tech 

industries now. 

A Simulink model allows you to design these intelligent algorithms and test them, before running them in 

the real world. In addition to that, the intelligent behavior can also be translated to code in different low-

level languages – e.g. C, HDL, PLC text – that can be deployed directly to embedded controllers like the 

Engine Control Unit (ECU) in your car. 

We will work with the code generation capability of Simulink for the rest of this workshop. Let’s take a look 

at the simulation capabilities to start with. 

Once you have created a Simulink model representing your system, and set up appropriate simulation 

parameters, you can just click on the green RUN button, and observe the behavior of your system over 

time.  

If you are curious, this is a simplified version of how Simulink works: 

When you click on the green run button (Figure 8), the Simulink model that you created with built-in or 

custom blocks is translated to an equivalent differential equation. Simulink then uses one of the built-in 

differential equation solvers, to solver this differential equation over time, and consequently, simulate the 

dynamic behavior of the system. 

Given the complex nature of this whole process, there are several pieces of information needed from the 

system designer – e.g. the nature of data exchanged between blocks, some notion about the dynamic 

nature of the system, simulation time and step size, interaction preferences, etc. All of these can be 

controlled by changing the appropriate settings in the ‘Model Configuration Parameters’ of each Simulink 

model. 

To learn more about key features of Simulink, check out the following webpage: 

http://www.mathworks.com/products/simulink/features.html  

If you want to see how simulation works: 

a. Open the model for simulating a bouncing ball, by typing sldemo_bounce at the MATLAB 

Command Prompt. 

b. Check model configuration from Simulation > Model Configuration Parameters 

c. Run the model by clicking on the green [Run] button to run the simulation and observe the behavior. 

 

http://www.mathworks.com/products/simulink/features.html
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P0.4 More on Simulink 

If you want to try out some more examples, go to Simulink documentation under: 

MATLAB Desktop > Help (Product Documentation) > Simulink > Examples 

Figure 5: Bouncing Ball Model 
(sldemo_bounce.slx) 

Figure 6: Simulink Model Configuration Parameters 

Figure 7: Run Button 

Figure 8: Bouncing Ball Visualization 
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Project 1: Sound-Tone Robot 

P1.1 Make the NXT Brick Beep Part 1 

Objective: Check hardware and software installation. 

Tasks/Challenge: 

 Run an existing model, SoundTone1.slx (Figure 9). 

 Press the orange [OK] button on the brick to make it beep. 

 

Figure 9: Simulink Model SountTone1.slx 

Steps/Approach: 

1. Copy the supplied model SoundTone1.slx into a directory of your choice, and within MATLAB 

navigate to that directory. 

2. Open the model by double-clicking on the file in the Current Directory browser. 

3. Check that the NXT Brick is powered on and connected to the host PC with a USB cable 

Select SoundTone1.slx > Tools > Run on Target Hardware > Options menu item, and check for the 

following settings and Click [OK] to close the window. 

 
Figure 10: SoundTone1 Settings 
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4. On the SoundTone1 model window, [Deploy] the model to the NXT (Figure 11). Note that: 

 This action initiates the build, download and run procedure. 

Progress is reported in the status bar at the bottom left of 

the model window, terminating with the message, ‘Model 

successfully downloaded …’ 

 The NXT can now be disconnected (if desired). 

 The build process automatically starts / runs the executable 

on the brick as can be observed from the NXT’s LCD screen 

(Figure 12). 

5. Whenever you now press the orange [OK] button on the brick (the chosen ‘Button’ in the model, 

see Figure 9) a tone is sounded. 

6. Terminate the execution by pressing the middle dark-

grey [Exit] button. 

 The NXT will automatically power off.  On power-

on, the NXT Brick will revert to the normal LEGO 

start screen. 

7. You can run a model that has already been downloaded 

to the NXT, by using the NXT button/menu interface: 

navigate to MyFiles > SoftwareFiles > SoundTone1 and 

select > Run. 

8. Restart the model while it is running, by pressing the left light-grey button on the NXT. 

Additional notes: 

 It may take a few seconds to open a Simulink model, unless you have already started Simulink. 

 It is not possible to compile the model without having an NXT connected, either via USB cable 

or via Bluetooth.  Simulink will throw an error message. 

 Tip: If you do not have a NXT, you can test the syntactic integrity of your model using the menu 

option Simulation > Update Diagram, (or simply [Ctrl-D]). 

  

Figure 11: Program NXT Brick 

Figure 12: NXT Brick LCD Display 
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P1.2 Make the NXT Brick Beep Part 2 

Objective: Learn how to create models in Simulink 

Task/Challenge: Re-construct the SoundTone1.slx (Figure 9) model from scratch to get familiar with the 

design process. 

Steps/Approach: 

1. [Open] the Simulink Library Browser. 

2. [Create] a new model and [Save] the new ‘untitled’ model as mySoundTone1.slx in a working 

directory. 

3. [Search] for the three blocks listed in the table below and [Drag and drop] them into the 

mySoundTone1.slx window. 

 

LIBRARY BLOCK PROPERTY SETTING/VALUE 

Simulink Support Package for 
LEGO MINDSTORMS NXT 
Hardware 

Button  Button Middle Orange 

Speaker  
Input Mode: 
Frequency (Hz): 
Speaker Duration (ms): 

Volume Only 
440 
100 

Commonly Used Blocks Gain  Gain: 50 

 

4. After configuring the Button, Speaker and Gain blocks according to the settings in the table above,  

their dialog boxes should look like this: 

 

 

 

 
 

 
 
 
 
 
 
 

 

 

5. Note the Speaker block settings. 

This will cause the speaker to sound 

continuously since the specified duration is 

greater than or equal to the model step size. 

  

Figure 13: Block Settings 
for SoundTone1.slx 
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6. Use Display > Signals and Ports > Port Data Types and select the Simulation > Update Diagram 

menu option (or Ctrl + D shortcut) to highlight signal types and potential mismatch/truncation 

issues. 

 The data types of NXT block inputs are automatically type cast to the appropriate data type for 

the underlying hardware, but it is good practice to be aware of the data types used in your 

model. 

7. To configure the model for real-time implementation on the NXT select Tools > Run on Target 

Hardware > Prepare to Run… and check for the following settings in the Run on Target Hardware 

and Solver panes (see Figures 7 & 8): 

 
Figure 14: Run on Target Hardware Pane 

 

Figure 15: Solver Pane 

8. Click [Apply] to apply the changes and [OK] to dismiss the dialog.  

It is also good practice to [Save] your work before proceeding to run the model. 

9. Verify that the NXT is powered-on and connected. 

10. [Deploy] the model to the NXT. 

11. Whenever you now press the orange [OK] button on the NXT a tone is sounded. 

12. Terminate the execution by pressing the middle dark-grey [Exit] button.  
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P1.3 Modulate Sound Frequency and Volume Part 1 

Objective: Learn how to design algorithms in Simulink 

Task/Challenge: 

Design a Simulink model that uses the two robot wheels to: 

 Modulate the tone about a center frequency of 440 Hz using the wheel attached to Port B 

 Modulate the tone volume using the wheel attached to Port C. 

 

Steps/Approach: 

1. Apply the same procedure as for mySoundTone1.slx to construct, build and test the 

SoundTone2.slx model (Figure 17). You will need these additional blocks: 

2. Here is a list of blocks and their initial settings 

LIBRARY BLOCK PROPERTY SETTING/VALUE 

Simulink Support Package for 
LEGO MINDSTORMS NXT 
Hardware 

Encoder  NXT Brick output port: B or C 

LCD  
Display Label: 
Display Line: 

Choose/set 
appropriately 

Commonly Used Blocks 
Constant  Constant Value: 

Volume = 50 
Frequency = 440 

Add 
Icon Shape: 
List of signs: 

Round or Rectangular 
++ 

3. When executing, the display on the LCD screen should look like the one in Figure 16. 

4. Rotate the wheels to change the volume and frequency of the sound tone. 

Additional notes 

 Note that the motors attached to robots have built-in encoders to measure the angular position of 

the motor 

 The tone frequency and volume signals used to drive the NXT Speaker are simultaneously displayed 

on the NXT Brick’s LCS screen using to two LCD blocks, one for each line of display  

Figure 17: SoundTone2.slx 

Figure 16: NXT Display for 
SoundTone2 
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P1.4 Modulate Sound Frequency and Volume Part 

Objective: Learn how to monitor and tune algorithm running on the NXT brick remotely. 

Task/Challenge: 

 Adapt the previous model to allow modifying the center frequency and volume remotely from the host 

computer by running the Simulink model in External Mode 

 Add features to remotely monitor the volume and to plot the frequency via Bluetooth® 

External Mode allows users to monitor sensor signals, and to modify or ‘tune’ parameters that control the 

NXT robot’s behavior while a compiled version of the Simulink model is running on the NXT Brick.  This 

provides a real-time, interactive environment to gain valuable insight into system behavior. It also helps in 

developing intuition about system dynamics in general. 

Figure 19: SoundTone3.slx 

Steps/Approach: 

1. Double-check that the host computer and the NXT are ‘paired’ via Bluetooth connection at the 

operating system level. See 0. If you are attending a workshop, the pairing has already been 

performed. 

2. Modify SoundTone2.slx to as shown in Figure 18. Use these additional blocks: 

LIBRARY BLOCK PROPERTY SETTING/VALUE 

Commonly Used Blocks 
Scope  

Limit data points to last: 
Y – min: 
Y – max: 

500 
50 
500 

Display  
Display Label: 
Display Line: 

Choose/set 
appropriately 

Figure 18: Scope Block Parameters 
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Look at the documentation to find out how to access parameters of 

the Scope block. To access the documentation for the block, right 

click on the block in the Simulink browser window and select ‘Help for 

the Scope block’ (Figure 20). 

 

4. [Save] the model as SoundTone3.slx. 

 The data will only be recorded if the program executes for more 

than the 50s specified. Sample time of 0.1s X 500 samples to 

record = 50s. 

5. Open the Tools > Run on Target Hardware > Options pane and 

configure the parameters as in Figure 21. If the COM port number is known from Step #1 > specify 

the port number, choose Manually, and specify the COM port number. Otherwise choose 

Automatically. 

 
Figure 21: Simulink Model Parameters for running in External Mode 

6. Set the simulation mode of the Simulink model to ‘External’ and Stop time to Inf (Figure 22). 

 
Figure 22: Simulink Model Settings to run in External Mode 

Figure 20: Get help for Scope Block 
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7. Having ensured the NXT is powered-on and connected, [Run] 

the model (see Figure 22). This will:  

 Generate code for the Simulink model, compile it and 

download the compiled version to the NXT Brick. 

 The host PC automatically establishes connection via 

Bluetooth, between the Simulink model on the computer 

and its compiled version running on the NXT Brick. 

 The model proceeds to execute on the NXT Brick, just as in 

Section P1.2 – but now with additional External Mode 

capabilities, which allows you to change the parameters in the Simulink model, and see its 

effect on the behavior of the NXT Brick. The USB cable may now be disconnected if desired. 

 If you notice, NXT Brick’s LCD screen shows an additional step after the model is downloaded to 

the NXT, the model sits waiting for the host to connect (Figure 23), before the execution starts. 

The recommended way to stop the execution of a model running in External Mode is to click on the [Stop] 

button on the Simulink model running on the host PC.  This will shut down the NXT Brick as well. DO NOT 

stop the model execution by hitting the [Exit] button on the NXT as before. This interrupts the Bluetooth 

communication between the NXT Brick and the computer, and puts Simulink in a waiting state. The only 

way to get out of that state is to wait for a timeout, or close Simulink. 

 

8. For Parameter Tuning: Double-click on the center frequency Constant block and change the value 

from 440 to 220 Hz. 

 The change automatically propagates to the target hardware via Bluetooth, and the frequency 

jumps instantly. 

9. For Signal Monitoring: 

 Observe how the value shown in the Volume Display block on the host PC changes as the 

volume is changed by rotating the wheels on the NXT. 

 Observe how the trace displayed in the Scope block changes as the frequency is changed on 

the NXT. 

 After executing the model for at least 50 seconds the recorded workspace data can be plotted 

manually using the following commands, or by selecting an appropriate plot from the PLOTS 

Tab. At the MATLAB command prompt enter: 

%Note: Scope block saved the data to workspace variable ScopeData 

>> plot(ScopeData(:,1),ScopeData(:,2)); 

>> xlabel('Time [sec]'); 

>> ylabel('Frequency [Hz]'); 

Additional Notes: 

 To re-run a model in External Mode, just repeat Step 7 above. 

 What is the data type of the output of the Encoder blocks?  [Hint:  See Section P1.2 Step #6].  

Figure 23: NXT waiting for host 
PC to connect 
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Project 2: Line-Following Robot 

P2.1 Line-following robot with Proportional Feedback 

Objective: Learn to model system behavior with Simulink 

Task/Challenge: The aim of this project is to: 

 Implement a simple robot controller which uses feedback from the light sensor to track a black line 

marked on a light colored floor.  

 Make the robot track the edge of the line, with black to the left, and white to the right. In other words, 

if the measured light is less than some pre-defined constant set point value, the robot should turn to 

the right. Conversely, if the received light is greater than the set point the robot should turn to the left. 

 

  

 

Steps/Approach: 

1. [Create] a new model and [Save] the new ‘untitled’ model as LineFollow1.slx in a working 

directory. 

2. [Drag and drop] the following blocks from the Library Browser into the LineFollow1.slx window to 

construct the model above. Configure the block parameters as follows: 

LIBRARY BLOCK PROPERTY SETTING/VALUE 

Simulink Support Package for 
LEGO MINDSTORMS NXT 
Hardware 

Light Sensor  NXT Brick input port: 
Choose/set 
appropriately 

Motor  NXT Brick output port: 
Choose/set 
appropriately 

Commonly Used Blocks 

Constant  Constant Value: 
Set Point = 30 (say) 
Base Speed = 20 (say) 

Sum 
Icon Shape: 
List of signs: 

Round or Rectangular 
Choose/set 
appropriately 

Gain Gain: 
Controller Gain = 2.5 
(say) 

Figure 25: LineFollow1.slx 
Figure 24: Line-Following Robot 
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3. Configure the model to run on the NXT in External mode as seen in the previous example. Also see 

Reference R2. 

4. Adjust the values of the system parameters Set Point, Base Speed and Gain in the Simulink model 

for good performance indicated by a fast, smooth, line-following behavior is achieved. 

Questions: 

 How can you estimate a good Set Point value for light intensity? 

 How does the system behave when the gain is too low? 

 How does the system behave when the gain is too high? 

 How would you describe the interaction (if any) between the base speed, and the gain? 

 What is the effect of adding some kind of friction to one of the wheels? 
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P2.2 Line-following Robot with Multiple Modes of Operation 

Objective: Learn to design complex system behavior in Simulink 

Task/Challenge: One difficulty with the previous line-following robot (LineFollow1.slx) is that the code 

starts executing as soon as the download is complete (worst case, before the robot has been placed on the 

track). The aim of this project is to implement a simple logic – a state machine – as follows: 

 State 0: Robot waits for the orange [OK] (the Enter) button to be pressed [to proceed to State 1]. 

 State 1: Robot tracks black line until the Enter button is pressed again [to return to State 0]. 

We will use a MATLAB Function block to define the finite state machine that implements the logic. 

MATLAB Function blocks can be used to define complex functional relationships that might otherwise be 

cumbersome to represent using interconnected block components. 

 

Figure 26: LineFollow2.slx 

Steps/Approach: 

1. [Create] a new model and [Save] the new ‘untitled’ model as LineFollow2.slx in a working 

directory. 

2. [Drag and drop] the following blocks from the Library Browser into the LineFollow2.slx window to 

construct the model above. Configure the parameters as listed in the table below. 

3. Double-click on the MATLAB Function block to edit its contents. 

4. Type in the code below into the editor that shows up. Note: 

a. Changes in the block’s inputs and outputs on changing the function signature 

b. Help provided by MATLAB Code Analyzer 

5. Save your model as LineFollow2.slx. 

6. Test and tune your model using External Mode, with a discrete solver sample time of 0.1 s. 
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LIBRARY BLOCK PROPERTY SETTING/VALUE 

Simulink Support Package for 
LEGO MINDSTORMS NXT 
Hardware 

Light Sensor  NXT Brick input port: 
Choose/set 
appropriately 

Motor  NXT Brick output port: 
Choose/set 
appropriately 

Button Button: 
Choose/set 
appropriately 

Simulink > Commonly Used 
Blocks 

Constant  Constant Value: 
Set Point = from P2.1 
Base Speed = from 
P2.1 

Sum 
Icon Shape: 
List of signs: 

Round or Rectangular 
Choose/set 
appropriately 

Gain Gain: 
Controller Gain = from 
P2.1 

Simulink > Sinks Display NA NA 

Simulink > User-Defined 
Functions 

MATLAB 

Function 
NA See code from below 

 

Code for MATLAB Function Block: 

function [currState,leftMotor,rightMotor] = 

control(btnPress,baseSpeed,gain,setpoint,sensedLight) 

%#codegen 

 

%Define persistent variables (values preserved between function calls) 

persistent state 

 

%Initialize persistent variables 

if isempty(state),                          % if no prior initialization 

state= 0;                               %   initial state 

end;                                        % end 

 

sensedLight= double(sensedLight);           % typecast the uint16 light reading 

leftMotor= 0;                               % default motor actions... 

rightMotor= 0;                              % ...both stopped 

 

switch state  % Define the Finite State Machine behavior for each state 

 

case 0  % WAIT!!                        % do nothing till btnPress 

if btnPress, state=1; end;          % then Run! => State 1 

 

case 1  % NORMAL OPERATION: RUN! 

err= sensedLight - setpoint;        % compute error signal 

leftMotor= baseSpeed - gain*err;    % adjust motor speeds according to 

rightMotor= baseSpeed + gain*err;   % ...baseSpeed, gain, and error 

if btnPress, state=0; end;          % stop when btn pressed => State 0 

 

otherwise                               % catches any rogue states 

state= 0;                           % goto default state 

end; 

 

currState= state;                           % return the current state 

  



December 23rd, 2013 

Page 24 of 35 
 

P2.3 Track Robot Position and Heading 

Objective: Learn to implement the mathematical representation of a physical system in Simulink 

Task/Challenge: The aim of this project is to use Simulink to model the kinematics of the robot so that the 

absolute x, y coordinates and robot heading  can be calculated from the left and right wheel Encoder 

blocks and displayed using an XY Graph block. 

 

Deriving the equations: 

1. Figure 27 illustrates how a wheel rotating though an angle d  (in radians) will travel a distance r.d  

forward along the ground.  Given a two-wheeled robot, with left and right wheels rotating through 

angles dL, dR ,(in degrees – since the encoder blocks output degrees), the approximate 

expression for the forward distance ds travelled by a point midway between the two wheels will be: 

    
       

 
 (1) 

2. Also the expression of the distance (dsL - dsR) that the left wheel has travelled further than the right 

wheel.  This same distance can be expressed in terms of the angle d and the distance L between 

the two wheels (see Figure 28).  Hence obtain an expression for d, the change in heading in a 

single time step. 

    
       

 
 (2) 

3. Assuming that the current heading is , and the distance travelled in the forward direction is ds, 

then the trigonometric expressions for the distances dx, and dy, travelled in the x and y directions 

respectively, are (see Figure 29), 

            
            

 (3) 

4. Given the expressions (2) for the small changes d, that occur in a single time step, it is easy to 

calculate the current values of , by incrementing the current value by d at each time step.  

Likewise, the current values of x and y can be found by incrementing them by dx, and dy 

respectively at each time step. 

      
             
             

        (4) 

 

Figure 28: Wheel motion in one time-
step Figure 27: Distance moved by a rotating 

wheel 
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Steps: 

1. Open the supplied LineFollow3.slx model 

2. Check the implementation of the equations above in the MATLAB Function block 

3. Estimate or measure values for the wheel radius r and axle length L of your robot in centimeters and 

update the appropriate variables in the code of the MATLAB Function block. 

4. Select the menu option Simulation > Mode > External from the Simulink model window to activate 

External Mode. 

5. Observe the trajectory of your robot on the XY Plot: 

a. Do you see the same pattern in the XY Graph as the shape of the track?  

b. How can you make the plot from successive loops overlap? 

 

 

Additional notes: 

 The Encoder blocks will output the angular change d  (in degrees) observed at each time step. 

 The output data type is int32. 

 The Data Type Conversion blocks convert int32 to a single or double precision floating point format. 

  

Figure 30: Resolving 
displacements in the X and Y 

directions 
Figure 29: LineFollow3.slx 

Figure 32: Live plot of robot position Figure 31: Plot after going around the track 
multiple times 
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Project 3: Additional Examples 

1. The Simulink Support Package for LEGO MINDSTORMS NXT Hardware has a number of examples 

that are distributed as part of the standard installation. To access those, just double click on the 

Examples block in the library for Simulink Support Package for LEGO MINDSTORMS NXT Hardware. 

2. Demos may be found in the C:\Matlab\SupportPackages\R2013b\lego\legodemos directory.  Copy 

the files to a working directory before compiling or modifying them. A current list of these examples 

is as follows: 

 lego_gettingstarted.mdl:  The output of the Button block is piped directly to a LCD Display 

block. 

 lego_communication.mdl: Demonstrates the use of External Mode in an example which plays 

songs to the user and responds to hand-clapping intensity to switch songs. 

 lego_drive_openloop.mdl: Drives a standard two-wheel robot with user-specified speed and 

turn angle (implemented as a speed difference between the two wheels).  The model includes 

a simulation of the motor response in parallel with the actual motor i/o. 

 lego_drive_closeloop.mdl: As above, but uses encoder feedback to achieve the specified turn 

rate. 

 lego_selfbalance.mdl:  A Segway-like mobile inverted pendulum example. 

 lego_explorer.mdl:  A Roving Explorer robot application that can perform several complex 

tasks autonomously or with guidance over the Bluetooth communication channel.  It uses 

many sensors and actuators. 
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Reference Materials 

R1 Deploying a Simulink model to the LEGO Mindstorms NXT 

1. Select Tools > Run on Target Hardware > Prepare to Run… 

2. Check for the following settings: In the Run on Target Hardware pane set Target Hardware to LEGO 

MINDSTORMS NXT: 

 

Figure 33: Configuration Parameters Dialog: Run on Target Hardware Pane 

3. In the Solver pane (see Figure 32) 

 Set the StopTime to inf (so the model will execute continuously on the NXT Intelligent Brick 

until physically stopped). 

 Set the SolverType to Fixed-step, and the Solver to discrete (no continuous states). 

 Set the Fixed-step size (the fundamental sample time) as appropriate for the application. In 

this case a sample period of 0.1 sec is acceptable. 

 

Figure 34: Configuration Parameters Dialog: Solver Pane 

4. Click [Apply] to apply the changes and [OK] to dismiss the dialog. 

5. It is also good practice to [Save] your work before proceeding to run the model. 

6. Verify that the NXT is powered-on and connected and [Deploy] the model to the brick. 
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R2 Running in External Mode using Bluetooth 

1. Double-check that the host computer and the NXT are ‘paired’ at the operating system level, see 

Reference R3. If you are attending a workshop, the pairing has already been performed. 

2. Open the Tools > Run on Target Hardware > Options pane and select the COM port number 

Manually, if the COM port number is known from Step #1 > specify the port number, otherwise 

choose Automatically. 

  
 

 

3. Set the simulation mode of the Simulink model to ‘External’ (Figure 34). 

4. Having ensured the NXT is powered-on and connected, [Run] the model (Figure 34). 

 The host automatically establishes connection and the model proceeds to execute, just as in 

Section P1.2 – but now with additional External Mode capabilities. The USB cable may now be 

disconnected if desired. 

 Careful observation of the progress reported in the status bar (and of the NXT’s LCD screen) shows 

an additional step after the model is downloaded to the NXT:  The model is automatically started 

on the NXT, but first sits waiting for the host to connect (Figure 33). 

  

Figure 35: Running simulation in External Mode 
Figure 36: NXT Brick waiting for 

host PC to connect 
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R3 Configuring Bluetooth at the system level 

Bluetooth Hardware and Drivers 

In order to communicate over Bluetooth with the NXT, the host computer must first have appropriate 

Bluetooth hardware and drivers. Some PC’s have this capability inbuilt into the system.  MathWorks 

recommends using the Bluetooth Dongle that you can purchase from LEGO’s website. 

For Windows 7 users, the drivers for such adaptors will generally install automatically when the dongle is 

first inserted. For Windows XP users, the driver specific for the dongle used may have to be downloaded 

and installed manually. For details see LEGO’s website. 

 

For the most up to date information see: 

http://www.mathworks.com/academia/lego-mindstorms-nxt-software/legomindstorms-simulink.html 

 

Bluetooth Pairing 

The NXT Intelligent Brick must first be ‘paired’ with the PC Bluetooth host.  This is a one off operation that 

occurs at the Windows operating system level.  Once configured, the two devices will pair automatically 

whenever within range of each other, so these steps should only need performing once. 

1. Using the NXT Intelligent Brick button/menu interface, navigate to Bluetooth/On|Off and turn 

Bluetooth On.  A small B< icon will appear in the top left corner of the screen to indicate that 

Bluetooth is enabled. 

2. On Windows7 platforms, from the Start Menu, open the system ControlPanel and select 

HardwareAndSound / ViewDevicesAndPrinters.  A window opens as shown in Figure 38. 

3. Check the NXT is powered on, and then Click Add a Device in the menu bar of this window.  The 

NXT should appear in the list of available devices to add.  Select this device and click next. 

4. On the NXT’s screen the default Passkey of 1234 is displayed.  Press the orange Enter button to 

accept. 

5. Enter the same 1234 pairing code when requested on the Windows system.  The pairing is then 

complete, and the NXT appears in the list of devices as shown in Error! Reference source not 

ound.. 

6. Double click on the newly added NXT device to examine its properties, select the hardware tab, 

and note the COM port number, e.g. COM9 that has been associated with the device. 

7. The NXT and/or PC may now be powered off, or re-programmed as many times as you like, but 

whenever the two are in range of each other, pairing should happen automatically and 

communication is possible through the assigned COM port number identified in step 6. 

http://www.legoeducation.us/eng/product/bluetooth_dongle/2647
http://www.mathworks.com/academia/lego-mindstorms-nxt-software/legomindstorms-simulink.html
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Figure 38: 'Devices and Printers' window 
before... 

Figure 37: ... and after pairing 
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The LEGO Mindstorms NXT 

Background Info 

The LEGO MINDSTORMS NXT provides a low-cost, yet remarkably powerful embedded target which 

includes a 32-bit 48 MHz processor, built-in H-bridge drivers, analog inputs, and audio, as well as USB and 

Bluetooth communications.  In order to harness this capability, however, it is necessary to have an 

appropriate programming pathway.  In this context, the Simulink enables high-level Simulink designs to be 

automatically cross-compiled for execution on the NXT Intelligent Brick without users having to engage in 

low-level programming.  Furthermore, Simulink’s ‘External Mode’ capability allows users to interact with, 

monitor and tune the code as it executes fully autonomously on the NXT Intelligent Brick 

Simulink’s support for low-cost hardware like LEGO MINDSTORMS NXT, Arduino, Raspberry Pi, BeagleBoard 

and PandaBoard is a new, professionally supported feature developed by the MathWorks, [1].  However, 

other tools with similar aims have previously been available on the MathWorks File Exchange site.  The 

Villanova University LEGO Real Time Target (VU-LRT), for example, is a similar tool developed with support 

from the National Science Foundation and the MathWorks Inc., aimed at exploiting Simulink code 

generation tools and low-cost hardware platforms for educational purposes (NSF grant # DUE No. 

0837637), [2]-[5].   Another (earlier) contribution, the Embedded Coder Robot (ECRobot), [6], also enabled 

real time code generation from Simulink to an NXT target, although user designs were sometimes 

constrained by ECRobot's function call and data store architecture.  It should also be noted that all these 

tools, including the latest Simulink Support Package for LEGO® MINDSTORMS® NXT™ Hardware, rely on 

nxtOSEK – a real time operating system for the LEGO NXT Intelligent Brick [7]. 

http://www.mathworks.com/matlabcentral/fileexchange/
http://www.mathworks.com/matlabcentral/fileexchange/29857
http://www.mathworks.com/matlabcentral/fileexchange/13399
http://lejos-osek.sourceforge.net/
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Working with LEGO Mindstorms NXT 

Basic NXT Intelligent Brick information: 

1. Ports on top of the NXT Intelligent Brick: 

a. Three ACTUATOR ports on top labeled A, B and C – connect motors to these. 

b. One USB port – connect the NXT Intelligent Brick to the computer. Update firmware or 

download compiled Simulink models 

2. Ports at the bottom of the NXT Intelligent Brick: 

a. Four SENSOR ports labeled 1, 2, 3 and 4 – connect different kinds of sensors like Ultrasonic, 

Sound, Touch, etc. to 

LEGO NXT Sensors: 

Here is a summary of some interesting information about the LEGO NXT Sensors. For detailed information 

about the sensor, visit LEGO’s website. For use in a Simulink model, read documentation on corresponding 

blocks. 

Sensor/Block Good to know 

Encoders Encoders are built into the motors themselves. They give current angle of the 
motor with respect to starting value of 0. The reading can be reset. 

Ultrasonic Sensor Gives a distance value between 0-255 cm 

Motors Accept inputs between -100 and 100. Need at least 7 (or -7) to overcome static 
friction. 

Color Sensor Can ‘see’ only 6 colors – RGYBlueBlackW. Object needs to be about 2-3 cm from the 
sensor for good color detection 

Sound Sensor Captures sound INTENSITY not AUDIO SIGNAL. Louder the sound, bigger the 
reading. 

Touch Sensor Binary output – 0 or 1 

Light Sensor Captures light INTENSITY. Good for differentiating between dark and light. 

If things don’t work: 

1. Encoders are built into the motors. Read motor angle with the Encoder blocks. 

2. Check that batteries/battery pack is charged and the NXT Intelligent Brick turns ON 

3. Check that SENSOR/ACTUATOR port numbers in the Simulink model correspond to the actual 

connections on the NXT Intelligent Brick 

4. Check the Bluetooth settings in Tools > Run on Target Hardware > Options for the following are 

correct/expected: 

a. Host to target connection 

i. USB for wired connection OR 

ii. Bluetooth with CORRECT Device name (name of the NXT Intelligent Brick seen on 

the LCD display of the NXT Intelligent Brick) 

b. Signal Monitoring and Parameter Tuning 

i. Enable External mode is disabled OR 

ii. Enabled with Automatic COM port or CORRECT COM port  
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Appendix 1: System Requirements and Setup for this workshop 

 Operating system:  Windows (tested under Windows 7) 

 32-bit or 64-bit MATLAB, and Simulink R2013b 

 If using 64-bit MATLAB, it will be necessary to install a compatible C compiler, see Section 4.1. 

 Bluetooth:  Bluetooth 2.0 adapter (tested with LEGO Bluetooth Dongle) 

 LEGO® MINDSTORMS Education NXT Base Set;   Additional construction parts: Education Resource Set 

 A collection of related third party tools / products which are installed automatically by the 

SUPPORTPACKAGEINSTALLER tool (see section 4 below). A detailed list of these tools / products, their 

function, and licensing details is provided during the installation process. 

Beginning release R2012a, Simulink Support Package for LEGO® MINDSTORMS® NXT™ Hardware does 
not require any additional toolboxes beyond those listed above. 

Step 1:  Install and ‘Select’ a C Mex Compiler for MATLAB and Simulink 

Simulink requires a C compiler in order to compile C-code automatically generated for the MATLAB 

Function block, which would be downloaded on the NXT Intelligent Brick.  This compiler must be installed 

and ‘selected’ prior to using Simulink Support Package for LEGO® MINDSTORMS® NXT™ Hardware. 

1. Check whether you are running the 32-bit (PCWIN) or 64-bit (PCWIN64) version of MATLAB by 

typing computer at the MATLAB prompt. 

2. 32-bit Versions of MATLAB ship with a C mex compiler. 64-bit versions of MATLAB do not ship with 

a C mex compiler. In this case, download and install a supported compiler.  (The Microsoft 

Windows SDK is free of charge.) 

3. Type mex-setup at the MATLAB prompt and following the on-screen prompts to do select a C mex 

compiler for MATLAB and Simulink to use. 

Step 2:  Automated Download and Install of the LEGO MINDSTORMS NXT Support 

Brief installation notes are provided below. More detailed installation instructions, including screen shots 

can be found in Help > Simulink > Target Hardware > LEGO MINDSTORMS NXT  Hardware> Install Support 

for LEGO MINDSTORMS NXT Hardware. 

1. Start the 

a. Going to MATLAB Desktop > Add-Ons > Get Hardware 

Support Packages 

b. OR, at the MATLAB prompt, type 

supportPackageInstaller 

2. On Windows 7 platforms, you will be prompted to allow 

MATLAB to restart in Administrator Mode in order to permit 

installation of new software.  Click OK. 

3. On the Select and Action page of the target installer, select 

‘Install from Internet’, then click Next 

4. On the Select Support Package to Install page, select LEGO MINDSTORMS NXT, then click Next 

5. On the next page, accept the agreement 

6. The following page lists the third party software that will be installed.  Click Install. 

Figure 39: Getting hardware 
support packages 

http://shop.lego.com/en-US/Bluetooth-Dongle-9847
http://www.legoeducation.us/store/detail.aspx?ID=1263&bhcp=1
http://www.legoeducation.us/store/detail.aspx?ID=1277
http://www.mathworks.de/support/compilers/R2013b/index.html
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7. At the Installation Complete page (which appears after a few minutes), select Close to exit 

installation.  [The screen also gives the option to continue to update the firmware on the NXT 

Intelligent Brick, but this is not necessary if the NXT Intelligent Brick already has updated firmware.]  
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